The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel 's EA, can we have older version?

Discussion in 'General Discussion' started by ikillbill, Jan 15, 2010.

  1. ikillbill

    ikillbill Well-Known Member

    Joined:
    Feb 18, 2008
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    PHP 5.2.11
    apache 2.2
    MySQL 5

    everytime we complile apache with EA by using easypache
    apache went crazily every couple of hours

    tried to manually install EA 9.5.3 , not able to install

    could cpanel team get EA 9.5.3 back to easyapache please?

    thanks
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please be aware that eAccelerator is a third-party module; furthermore, cPanel EasyApache will use only the latest version of eAccelerator that works with the latest available PHP versions. Please note that the specified older release of eAccelerator, version 0.9.5.3, is not compatible with the latest PHP version 5.3.1.

    To use an older version of eAccelerator it must be manually compiled; this is not a difficult task and may be accomplished by referencing the eAccelerator documentation: Install From Source - eAccelerator - Trac

    For support using eAccelerator I recommend referring to the third-party vendor's official support channels, such as their official eAccelerator Users mailing list as referenced here: Mailing List - eAccelerator - Trac
     
  3. veronicabend

    veronicabend Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    If I compile the older eAccelerator version manually, will it still be kept if I use easyapache in the future to recompile php to a newer version?

    Thanks.
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    From what I have seen in the past and to the best of my knowledge it will not remove or modify an existing custom extension; however, if the version of the extension is not compatible with selected PHP version then there will be inherent difficulty until the custom extension is upgraded. Using EasyApache Hook Scripts you could also have customizations backed-up prior to the build (e.g., preeasyapache) or other actions, including to compile and install any custom modules or extensions. Another option to have different versions is to use a custom option modules for EasyApache3 (as detailed in the documentation linked below).

    Reference documentation:
    EasyApache Hook Scripts
    EasyApache Custom Modules
     
Loading...

Share This Page