The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel Service Monitor exim-465,587 failed

Discussion in 'E-mail Discussions' started by shortfork, Jul 4, 2013.

  1. shortfork

    shortfork Well-Known Member

    Joined:
    Sep 4, 2006
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Gaaa... I added port 465 for secure mail, it's open on the firewall and functioning but since enabling it, about every six minutes I get an error from the service monitor..

    Code:
    Reason: Timeout while trying to get data from service: Died at /usr/local/cpanel/Cpanel/TailWatch/ChkServd.pm line 812.
    If I remove port 465 via WHM/ Service Configuration »Service Manager error stops. I do have the monitor box checked... I've done email tests via port 465 and all seems well.. Read somewhere else that it's only a problem of tailwatched not being able to connect to port 465.. yet, port 465 is open and apf allows 127.0.0.1

    I'm just going to disable monitoring for now but is this truly a problem or a bug or??

    TIA!!!

    Wayne
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    I don't think you can add port 465 in the service manager. Exim is already listening in port 465, and probably chkservd is not able to check a SMTPS port.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Port 465 for TLS/SSL SMTP is already enabled by default with cPanel/WHM. There is no need to add it as an additional port in the "Service Manager". You can remove it from the "Service Manager" and confirm it's still listening for connections. EX:

    Code:
    root@vps [~]# netstat -lnp | grep :465
    tcp        0      0 0.0.0.0:465                 0.0.0.0:*                   LISTEN      26213/exim          
    tcp        0      0 :::465                      :::*                        LISTEN      26213/exim
    Thank you.
     
  4. shortfork

    shortfork Well-Known Member

    Joined:
    Sep 4, 2006
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Ahh.. that's it, removed it from alternate port and all's well..

    THANKS!
     
Loading...

Share This Page