[cPanel smartcheck] Possible Hard Drive Failure Soon - False Positive ?

bgqs

Member
May 24, 2007
17
0
151
Code:
S.M.A.R.T Errors on /dev/sda
               From Command: /usr/sbin/smartctl -q errorsonly -H -l selftest -l error /dev/sda
               Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
190 Unknown_Attribute       0x0022   063   043   045    Old_age   Always   In_the_past 314255605797
               ----END /dev/sda--
I am getting these quite regular now. Is my HD on its way out ? Thanks in advance ;)
 

idealso

Active Member
Mar 1, 2007
28
0
151
If that hard drive is definitely failing, I could not say. However, hard drives are cheap. Any drive which begins getting SMART errors does not belong in a server or any other important capacity where you might actually miss whatever is on it if it dies.
 

JonMarkGo

Active Member
Sep 14, 2005
25
0
151
This seems to be a pretty common issue that the cPanel team just hasn't gotten around to fixing (from what I've read they're just using a really old version of smartcheck). Does anyone know a way to manually upgrade it and to correctly configure the cpanel smartcheck script?
 

ike

Well-Known Member
Apr 22, 2003
47
0
156
I've recently updated my kernal for linux and ever since have received these smart check hdd failure emails. I would like to think it just might be the fact i updated the kernal to the latest build thats giving me a false positive but dont know too much about smartcheck as ive never seen it before i updated the kernal. anyone got any more info on this or another way to test the hdd? changing hdds and the downtime for it would be terrible if i didnt have to do it. i did back everything up just in case though but your post about it being old did give me hope :) any help or ideas would be greatly appreciated.
 

hikaro

Well-Known Member
Nov 22, 2005
99
0
166
Hi,

From my experience, this is only appear on centos 4.6
because you do not turn off smartcheck on bios settings, when you turn off this issue will be solve,
i hv 10+ box having same problem but none of them having hdd error :)

just ignore the msg
 

ike

Well-Known Member
Apr 22, 2003
47
0
156
im running centos 5 with version 2.6.18-53.1.13.el5

and never had the error before i upgraded my kernal last week.
 

jayh38

Well-Known Member
Mar 3, 2006
1,213
0
166
Whats the age of the drive, 3 years? I would heed the warning unless you can live without your primary drive (which I doubt). You could run a file check on the next reboot and see if you get anything unrepairable.
 

ike

Well-Known Member
Apr 22, 2003
47
0
156
no idea the age of the drive. i pay for a ded box from a company and the server is only 5 months old. i would not have a clue how old the actual drive is personally.
 

zobmaster

Registered
Jan 21, 2006
3
0
151
I'm getting this mail daily since my admin updated whm and Cpanel. What should I do?.. You're talking about turning off smartcheck on bios settings, but I couldn't find anything about it in WHM

S.M.A.R.T Errors on /dev/sda
From Command: /usr/sbin/smartctl -q errorsonly -H -l selftest -l error /dev/sda
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
190 Unknown_Attribute 0x0022 054 038 045 Old_age Always In_the_past 46
----END /dev/sda--

S.M.A.R.T Errors on /dev/sdb
From Command: /usr/sbin/smartctl -q errorsonly -H -l selftest -l error /dev/sdb
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
190 Unknown_Attribute 0x0022 048 042 045 Old_age Always In_the_past 52
----END /dev/sdb--
 
Last edited:

isputra

Well-Known Member
May 3, 2003
575
0
166
Mbelitar
I'm getting this mail daily since my admin updated whm and Cpanel. What should I do?.. You're talking about turning off smartcheck on bios settings, but I couldn't find anything about it in WHM
If you want to turning off smartcheck on bios, you have to reboot your server and edit your bios server. This is not something in WHM you can turning off but in your Motherboard BIOS setting.