The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel + Spamassassin (and exim too ;)

Discussion in 'General Discussion' started by stassy, Dec 30, 2004.

  1. stassy

    stassy Registered

    Dec 30, 2004
    Likes Received:
    Trophy Points:

    It's the first time I use cPanel
    I create account and an email for this account.
    When I send a mail to this account, it works fine.

    Here is the /var/log/exim/mainlog :
    2004-12-30 20:10:31 1Ck5gt-000Axk-Cf <= H=( [] P=esmtp S=1806
    2004-12-30 20:10:32 1Ck5gt-000Axk-Cf => patrick <> R=virtual_user T=virtual_userdelivery
    2004-12-30 20:10:32 1Ck5gt-000Axk-Cf Completed

    And when I activate spamassassin in the for the domain, I have the following error :
    2004-12-30 20:15:14 1Ck5lS-000B0P-6s <= H=( [] P=esmtp S=1806
    2004-12-30 20:15:14 SMTP connection from sauveur lost while reading message data (header)
    2004-12-30 20:15:14 1Ck5lS-000B0P-6s <>: virtual_sa_userdelivery transport output: An error was detected while processing a file of BSMTP input.
    2004-12-30 20:15:14 1Ck5lS-000B0P-6s ** R=virtual_sa_user T=virtual_sa_userdelivery: Child process of virtual_sa_userdelivery transport returned 2 from command: /usr/sbin/sendmail
    2004-12-30 20:15:14 1Ck5lS-000B0X-Pp <= <> R=1Ck5lS-000B0P-6s U=mailnull P=local S=3141
    2004-12-30 20:15:14 1Ck5lS-000B0P-6s Completed
    2004-12-30 20:15:15 1Ck5lS-000B0X-Pp => R=lookuphost T=remote_smtp []
    2004-12-30 20:15:15 1Ck5lS-000B0X-Pp Completed

    The email is not send and i have a email back from (i suppose) exim :
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:
    local delivery failed

    The following text was generated during the delivery attempt:

    ------ ------

    An error was detected while processing a file of BSMTP input.
    The error message was:

    421 Lost incoming connection

    The SMTP transaction started in line 0.
    The error was detected in line 3.
    0 previous messages were successfully processed.
    The rest of the batch was abandoned.
    421 Lost incoming connection
    Transaction started in line 0
    Error detected in line 3

    ------ This is a copy of the message, including all the headers. ------

    I'm sure, someone already had this problem.
    Please help a poor man :)

    Thanks a lot

  2. dalem

    dalem Well-Known Member

    Oct 24, 2003
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    DataCenter Provider
    /scripts/perlinstaller Digest::SHA1
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd

    the above might fix the issue for you

    if not this is a bug I thought cpanel had all ready resolved? there is a patch for spamassin in the thread below

Share This Page