The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel SSL Certificate seen as invalid

Discussion in 'Security' started by nivekau, Sep 1, 2016.

Tags:
  1. nivekau

    nivekau Member

    Joined:
    Jul 22, 2011
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    I was pleased to receive the email today regarding the free cPanel SSL Certificate, however browsers and a mail client (Thunderbird) say it's invalid.

    Why would that be?
     
  2. SysSachin

    SysSachin Well-Known Member

    Joined:
    Aug 23, 2015
    Messages:
    323
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    When your cPanel service is 30 days from expiration, your server sends you reminder email notifications.

    To reset cPanel service's self-signed SSL certificate, perform the following steps:

    1. Log in to WHM as the root user.
    2.Navigate to WHM's Manage SSL Certificates interface (Home >> Service Configuration >> Manage SSL Certificates).
    3.In the Actions column, click Reset Certificate for the desired service.


    Please refer this URL for more help : How to Reset SSL Certificates for cPanel Services - cPanel Knowledge Base - cPanel Documentation
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know the specific error message you see in your web browser? Regarding your email client, could you verify if you are using the hostname of the server as the mail server name?

    Thank you.
     
  4. nivekau

    nivekau Member

    Joined:
    Jul 22, 2011
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    Sorry about the delay in responding. This is what I am seeing in Google Chrome when I go my login page for WHM ;

    Your connection is not private

    Attackers might be trying to steal your information from 122.100.xxx.205 (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID
    Automatically report details of possible security incidents to Google.

    This server could not prove that it is 122.100.xxx.205; its security certificate is from svrx.xxxxxx.net. This may be caused by a misconfiguration or an attacker intercepting your connection.

    Proceed to 122.100.xxx.205 (unsafe)​
     
  5. nivekau

    nivekau Member

    Joined:
    Jul 22, 2011
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    Re the mail client, I was using the mail server name. I have got around that problem for the time being by enabling POP before SMTP.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  7. nivekau

    nivekau Member

    Joined:
    Jul 22, 2011
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    Thanks.

    Problem solved. I just needed to access WHM via the server name rather than via the IP address, because it is the server name that the certificate was issued for
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page