Cpanel SSL certificates get The system failed to fetch the DCV (Domain Control Validation)

Miguel G

Well-Known Member
Jun 4, 2015
86
0
6
Spain
cPanel Access Level
Root Administrator
Twitter
I have WHM 60 (updated from last night build 19)

I have enabled Cpanel SSL market place and with an account that I own I could start the buying process a few days ago, but now I can´t either.

She gets this error:
Code:
Resolution Failed “The system failed to fetch the DCV (Domain Control Validation) file at “mysite.com/4341.UAPI_PL__.PSrR8_xv.cpaneldcv" because of an error: El sistema no pudo enviar una solicitud HTTP (Protocolo de Transferencia de Hipertexto) “GET” a
“/mysite.com/4341.UAPI_PL__.PSrR8_xv.cpaneldcv” debido a un error: Could not connect to 'mysite.com:80': Connection refused The system failed to send an HTTP (Hypertext Transfer Protocol) “GET” request to “/mysite.com/4341.UAPI_PL__.PSrR8_xv.cpaneldcv”because of an error: Could not connect to 'mysite.com:80': Connection refused .”
Maybe something related to the last update?
 
Last edited by a moderator:

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
807
160
168
New Jersey
cPanel Access Level
DataCenter Provider
Connection refused

I would try disabling your firewall and IPtables then try again just to see if its the firewall blocking the incoming request.

Or it could be as simple as the domain being misspelled, can you actually go to 'mysite.com'(obviously the real domain that shows in the error)

You can also monitor the access logs to see if the actual request is coming in:

Code:
# tail -f /usr/local/apache/domlogs/mysite.com
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,498
1,971
363
cPanel Access Level
Root Administrator
@babel13 - the errors you posted, which I redacted as we can't post domains or IP addresses due to security reasons, are due to DNS issues with the domain. I would recommend scanning the domain name at intodns.com and making sure everything there checks out normally, but AutoSSL will not work properly until those issues are resolved.