The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel ssl connect problem...

Discussion in 'General Discussion' started by inshune, Oct 16, 2009.

  1. inshune

    inshune Registered

    Joined:
    Nov 2, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    FF SSL Error code: ssl_error_rx_record_too_long
    IE SSL Error code: The page cannot be displayed.

    Now if a client goes for self signed certificates, or even installing one (trial from comodo 30days free)

    the error Error code: ssl_error_rx_record_too_long comes up.

    I have connected fine to the site doing http:// :443 and it goes to the default cpanel apache page.

    mod_ssl is installed. already start...
    433 port is opened...

    Any suggestions?
     
  2. UmbraHosting

    UmbraHosting Member

    Joined:
    Mar 12, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Did you receive any errors during the SSL certificate install? Is the certificate installed for an account with a dedicated IP address?

    Some certificates comes with certificate bundles, or CA bundles, that allow the cert to work properly.
     
  3. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Do you have root (System Administrator) access to the server?

    What method was used to install the SSL certificate? (e.g., via cPanel, or via WHM)
     
  4. aspardeshi

    aspardeshi Member

    Joined:
    Oct 22, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    try changing firewall settings

    try changing firewall settings, it may be blocking the port ! :)
     
Loading...

Share This Page