cpanel SSL errors in /var/log/messages

lewlew

Registered
Nov 14, 2003
1
0
151
Nov 25 17:31:24 shells stunnel[92563]: stunnel 4.04 on i386-unknown-freebsd5.1 PTHREAD+LIBWRAP with OpenSSL 0.9.7c 30 Sep 2003
Nov 25 17:31:24 shells stunnel[92563]: Error reading certificate file: /usr/local/cpanel/etc/cpanel.pem

Nov 25 17:31:24 shells stunnel[92563]: error stack: 140DC009 : error:140DC009:SSL routines:SSL_CTX_use_certificate_chain_file:PEM lib

Nov 25 17:31:24 shells stunnel[92563]:
SSL_CTX_use_certificate_chain_file: 906D06C: error:0906D06C:PEM routines:PEM_read_bio:no start line

What should I do to fix this? thanks for the time'
 

easyhoster1

Well-Known Member
Sep 25, 2003
656
0
166
Ok, for some reason, when we upgraded cpanel to the new cPanel 10.6.0-R55 it totally removed openssl. Reinstalling openssl fixed the problem.
 

Santoman

Member
Mar 8, 2002
18
0
301
Got the same thing this morning...

Guess I shouldn't have updated... :(

A quicky on how to update openssl? DO not feel like thinking this morning. :)

Thanks,


Steve
 

easyhoster1

Well-Known Member
Sep 25, 2003
656
0
166
Santoman said:
Guess I shouldn't have updated... :(

A quicky on how to update openssl? DO not feel like thinking this morning. :)

Thanks,


Steve
We use FREEBSD; as root

cd /usr/ports
make fetchndex
cd /usr/ports/security/openssl
make deinstall clean
make depend; make ; make install
 
Last edited:

Santoman

Member
Mar 8, 2002
18
0
301
easyhoster1 said:
We use FREEBSD; as root

cd /usr/ports
make fetchndex
cd /usr/ports/security/openssl
make deinstall clean
make depend; make ; make install
So, the fine folks that removed openssl, aren't providing a quick way to fix it?