The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel ssl

Discussion in 'General Discussion' started by techteen, Apr 30, 2006.

  1. techteen

    techteen Active Member

    Joined:
    Jul 31, 2004
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have a problem. The Cpanel SSL service (the one that lets me us eport 2087 and etc) wont start. When you restart cpanel the service will fail every time. I amd the datacenter i use have tried to fix the problem. We tried /scripts/upcp and /scripts/fixeveyrthing and so on. Nothing seems to work, is there any ideas on how to fix this?

    I am fresh out of thoughts. I do not want to reinstall the server because i got to pay by the minute its down and etc.

    So i mean i need a solution to fix this and still keep my server up for the clients.

    any ideas?
     
  2. sparksupport

    sparksupport Member

    Joined:
    Apr 30, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    Try running this from shell /usr/local/cpanel/startup and paste the output

    Also tail the log tail -f /usr/local/cpanel/logs/error_log
     
  3. xerophyte

    xerophyte Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    and make sure you have stunnel is running

    cpanel 14604 0.0 0.1 3760 1696 ? Ss Apr29 0:00 /usr/bin/stunnel-4.04local /usr/local/cpanel/etc/stunnel/default/stunnel.conf.run
     
  4. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    It is difficult to say without more information. As sparksupport suggested, check the log files for errors:
    /var/log/messages and
    /usr/local/cpanel/logs/error_log
     
  5. elmister

    elmister Active Member

    Joined:
    Mar 2, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem in a new server, with the latest 10.8.2 R63, the problem seems to be that it looks for libssl.so.0.9.7 instead of the installed libssl.so.0.9.7a

    I've downgraded to Stable 114, and is working ok
     
  6. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    just create a symbolic link for correct library.

    ln -s libssl.so.0.9.7f libssl.so.0.9.7
     
  7. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
  8. wilfried

    wilfried Active Member

    Joined:
    Aug 23, 2003
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    So is there a solution besides downgrade to stable?
     
Loading...

Share This Page