eMtnMan

Member
Sep 15, 2003
14
0
151
Re: Re: FIXED!

Originally posted by DPartridge
Can somebody on the forum please explain to me how to run the Layer 2 update?
SEE ABOVE POST! I see someone posted the fix at the same time as my response...

In my case, the fix was performed by RackShack/EV1 support. All I saw was a broadcast message about the level 2 update. I've asked them how it was done, I'll let you know when they reply.

In the meantime, you might also want to enter a trouble ticket both here and at your ISP...

Good Luck!
 
Last edited:

DPartridge

Registered
Sep 20, 2003
2
0
151
Originally posted by Infopro
Sure, login with SSH and su - to root. Type (or paste) this in:
rm -f /usr/local/cpanel/cpanel

That wiped the old, now in with the new:
/scripts/upcp

Same as the first line, type it in (or paste) and hit enter.

All done. :D
And it worked perfectly. I appreciate the help!

Dennis
 

sitesurf

Registered
Nov 29, 2003
1
0
151
cPanel /WHM gone

Hello,

New here, but I'm having big problems. From what I can gather, WHM did an auto update this morning and now all is gone. Server is running, sites are live, but I have no access to WHM or any cPanel instance for any domain (about 75 on server). From this thread, and the threads I have read at Server Beach (where the box lives), I take it there was a bug in the update that went out this morn. But what I don't understand is how do I proactively do something about this. I can gain FTP access to the server, but don't know what to do, if anything, to manually fix this issue. Any help would be greatly appreciated.

Bill Shaw
Managing Partner
Sitesurfer Publishing LLC
 

AceWeb

Well-Known Member
Aug 9, 2002
60
0
156
Re: cPanel /WHM gone

Originally posted by sitesurf
Hello,

New here, but I'm having big problems. From what I can gather, WHM did an auto update this morning and now all is gone. Server is running, sites are live, but I have no access to WHM or any cPanel instance for any domain (about 75 on server). From this thread, and the threads I have read at Server Beach (where the box lives), I take it there was a bug in the update that went out this morn. But what I don't understand is how do I proactively do something about this. I can gain FTP access to the server, but don't know what to do, if anything, to manually fix this issue. Any help would be greatly appreciated.

Bill Shaw
Managing Partner
Sitesurfer Publishing LLC
Have you tried removing /usr/local/cpanel/cpanel and running /scripts/upcp ?
 

zanboor

Member
Jan 14, 2004
5
0
151
I too have he same problems with cPanel/RHE 3.

I ran:
/scripts/updatenow
I got:
rsync: getaddrinfo: rsync.cpanel.net 873: Name or service not known
rsync error: error in socket IO (code 10) at clientserver.c(83)

I removed the /usr/local/cpanel/cpanel and then I ran:
/scripts/upcp
I got:

PHP version file is up to date
Doing a manual update...
Cpanel updates are coming from layer2.cpanel.net
SENT ipcheck email
send to CONTACTEMAIL (3) [2]
Checking /dev/hda....OK
x - creating lock directory
x - SKIPPING /usr/local/lib/php.ini (file already exists)
Using Mysql4
Error communicating with server. The message was:
Name or service not known
Error communicating with server. The message was:
Name or service not known
Testing connection speed...(this could take a while)....Done
Five usable mirrors located
CPAN: Storable loaded ok
Going to read /home/.cpan/Metadata
Database was generated on Fri, 06 Feb 2004 11:55:39 GMT
Net::AIM is up to date.
Net::SSLeay is up to date.
Tree::MultiNode is up to date.
Tie::IxHash is up to date.
HTML::Entities is up to date.
DBI is up to date.
Data::ShowTable is up to date.
Mysql is up to date.
DBD::mysql is up to date.
CGI is up to date.
MD5 is up to date.
Digest::MD5 is up to date.
Mail::SpamAssassin is up to date.
Net::DNS is up to date.
Digest::MD5 is up to date.
MIME::Base64 is up to date.
URI::URL is up to date.
HTML::Tagset is up to date.
MIME::Base64 is up to date.
Digest::MD5 is up to date.
URI is up to date.
Net::FTP is up to date.
HTML::Tagset is up to date.
HTML::Parser is up to date.
HTML::HeadParser is up to date.
LWP is up to date.
Parse::RecDescent is up to date.
OLE::Storage_Lite is up to date.
Term::ReadKey is up to date.
Term::ReadLine::Perl is up to date.
Image::Size is up to date.
DBI is up to date.
Safe::Hole is up to date.
Tie::ShadowHash is up to date.
Business::UPS is up to date.
IO::Scalar is up to date.
SQL::Statement::Hash is up to date.
Storable is up to date.
MIME::Base64 is up to date.
Digest::MD5 is up to date.
URI is up to date.
Net::FTP is up to date.
HTML::Tagset is up to date.
HTML::Parser is up to date.
HTML::HeadParser is up to date.
LWP is up to date.
Spreadsheet::ParseExcel is up to date.
Spreadsheet::WriteExcel is up to date.
perlmod--Install done
Error communicating with server. The message was:
Name or service not known
Error communicating with server. The message was:
Name or service not known
Testing connection speed...(this could take a while)....Done
Five usable mirrors located
CPAN: Storable loaded ok
Going to read /home/.cpan/Metadata
Database was generated on Fri, 06 Feb 2004 11:55:39 GMT
Tree::MultiNode is up to date.
GD is up to date.
perlmod--Install done
GD installed ok
rsync: getaddrinfo: rsync.cpanel.net 873: Name or service not known
rsync error: error in socket IO (code 10) at clientserver.c(83)
Bad arg length for Socket::pack_sockaddr_in, length is 0, should be 4 at /usr/lib/perl5/5.8.1/i686-linux/Socket.pm line 373.

Any clues?

Z.

Originally posted by Infopro
I think it is good release. Have you not read why there was a problem?
 

zanboor

Member
Jan 14, 2004
5
0
151
I am not sure howmany times one needs to run the rm cpanel and upcp!!

It's just NOT connecting to cpanel server.

I am looking at a different product now. I can't afford this.

Z.




Originally posted by Bailey
Folks, read this thread before posting to it.

The fix for cPanel/WHM not working right has been posted twice already, use it. ;)

:D Bailey
 

nzservers

Well-Known Member
Oct 27, 2002
81
0
156
errors

There was an error setting uids. Please have the admin check permissions on: /usr/local/cpanel/bin/mysqlwrap CP-Wrap Critcal Error (signal 13 from wrapped program)! This may indicate a corrupt admin binary in /usr/local/cpanel/bin/ / 999
change permissions on /usr/local/cpanel/bin/cpwrap to 04755 to fix that
 

dennis

Well-Known Member
Apr 22, 2003
88
0
156
Singapore
Originally posted by Infopro
Sure, login with SSH and su - to root. Type (or paste) this in:
rm -f /usr/local/cpanel/cpanel

That wiped the old, now in with the new:
/scripts/upcp

Same as the first line, type it in (or paste) and hit enter.

All done. :D
after i do this, will all my settings be gone? apache, php, mysql etc?