cPanel Store not issuing new certs

Curious Too

Well-Known Member
Aug 31, 2001
435
2
318
cPanel Access Level
Root Administrator
This morning several domains with expiring certs didn't get new certs issued. This was the error message in the Auto-SSL log:

ERROR AutoSSL failed to request an SSL certificate for “domain.com” because of an error: (XID v8w3e8) The cPanel Store returned an error (X::UnknownError) in response to the request “POST ssl/certificate/free”: Service Unavailable

Is anyone else having problems getting updated certs from the cPanel Store?
 
Last edited by a moderator:

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
535
247
118
IN
cPanel Access Level
Root Administrator
Yes, facing the same issue.
To get the SSL renewed/installed we have to try multiple times.
 

nshah14285

Member
May 26, 2011
16
1
53
Hello,

Using WHM 104.0.8.
Since yesterday, facing the same issue.
Tried multiple times but SSL certificate is not getting renewed or installed.
Even tried today morning with no luck.

Sectigo IP's are also allowed in firewall.
  • 178.255.81.12
  • 178.255.81.13
  • 91.199.212.132
  • 199.66.201.132
  • 91.199.212.52
Sectigo completed their planned maintenance task and still, we are facing the issue with SSL renewal.

This is the email server domain and is now at critical risk from last 2 days.

Errors are

ERROR AutoSSL failed to request an SSL certificate for “example.com” because of an error: (XID e3ufdz) The response to the HTTP (Hypertext Transfer Protocol) “POST” request from “https://store.cpanel.net/json-api/ssl/certificate/free” indicated an error (500, Internal Server Error): <!DOCTYPE HTML PUBLIC "-//IETF/…

ERROR AutoSSL failed The “cPanel (powered by Sectigo)” provider cannot currently accept incoming requests. The system will try again later.

ERROR AutoSSL failed to request an SSL certificate for “example.com” because of an error: (XID n3kb7h) The cPanel Store returned an error (X::UnknownError) in response to the request “POST ssl/certificate/free”: Service Unavailable

Please help to fix this issue.
 
Last edited:

nshah14285

Member
May 26, 2011
16
1
53
Hello,

The issue got fixed and the SSL is renewed for the domains.
I have run the AutoSSL again for the domain and this time it worked.

So either the issue is from the cPanel or SSL service provider SECTIGO side.
 

kodeslogic

Well-Known Member
PartnerNOC
Apr 26, 2020
535
247
118
IN
cPanel Access Level
Root Administrator
Glad you were able to fix it.