The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel subdomain A record issue

Discussion in 'General Discussion' started by molcomp, Apr 5, 2013.

  1. molcomp

    molcomp Member

    Joined:
    Feb 28, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello

    I have 3 cpanel servers in a dns cluster. One is whm/cpanel and the other two are cpanel dns only. When I check any subdomain using dig command against the whm/cpanel server I do not receive in reply the ip address for the A record. If I check with dig the subdomain of the server itself /hostname I get the IP address without any problem. If I check the subdomains with dig command against the other two cpanel dns only servers I receive a proper reply for A record showing me the IP address. I appreciate any thoughts on the issue why the whm/cpanel server is not returning the IP address for its A record.

    Alex
     
  2. molcomp

    molcomp Member

    Joined:
    Feb 28, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    An additional info I have just noticed. The WHM/Cpanel server is showing the IP address of the A record for the subdomains created as a subdomain under cpanel but it is not showing (via dig) the IP address of the subdomains which only exist in the dns record.
     
  3. molcomp

    molcomp Member

    Joined:
    Feb 28, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    The issue is fixed. The problem was that the subdomain dns zone file XXX.domain.com.db which was the third dns in the cluster had wrong name in the attributes.
     
Loading...

Share This Page