Galanthus

Well-Known Member
Nov 8, 2013
87
0
6
cPanel Access Level
Root Administrator
Glad to hear things are working. Everything looks good from my tests. Sorry that I wasn't able to be more clear on how to create those ns entries at transip.
No problem at all you helped me a lot!
I do have a question for you. I'v added myble.nl and it will create the account on the server.
When i TERMINATE account it is still visible in the browser i still can see the
/http://www.domain.nl/cgi-sys/defaultwebpage.cgi page.

I would like to ask you how can i remove this "/cgi-sys/defaultwebpage.cgi"and only show empty directory.

And when i add a subdomain for some reason when i delete it it still active.

So you dont see any errors anymore? everything ok now?

- - - Updated - - -

Glad to hear things are working. Everything looks good from my tests. Sorry that I wasn't able to be more clear on how to create those ns entries at transip.
Why am i still able to see erors: /http://intodns.com/domain.nl
 

KostonConsulting

Well-Known Member
Verifed Vendor
Jun 17, 2010
255
1
68
San Francisco, CA
cPanel Access Level
Root Administrator
No problem at all you helped me a lot!
I do have a question for you. I'v added domain.nl and it will create the account on the server.
When i TERMINATE account it is still visible in the browser i still can see the /http://www.domain.nl/cgi-sys/defaultwebpage.cgi page.

I would like to ask you how can i remove this "/cgi-sys/defaultwebpage.cgi"and only show empty directory.
Default webpage is a catch-all web page on cPanel and you get sent there when a website is not configured properly with Apache. I'd recommend submitting a support ticket to cPanel so they can help you track down the error as it will take the verification of a number of things on the server.

If you want to troubleshoot it manually, ensure these things:

1) That the DNS zone for domain.nl is complete and references ns01,ns02,ns03 as well.

2) That domain.nl has a VirtualHost entry in /usr/local/apache/conf/httpd.conf and it is directed to the proper directory and IP

3) That you can resolve domain.nl from SSH with this command:

dig @127.0.0.1 domain.nl

4) That you can get to the site by username: http://<IP>/~<USER>





And when i add a subdomain for some reason when i delete it it still active.

So you dont see any errors anymore? everything ok now?

- - - Updated - - -
DNS is a distributed system with many servers over the internet keeping a copy of your DNS records so they can direct traffic to your site. DNS is like a map to your website and so many servers need this map in order to know how to tell people where to go. As such, all those copies of the map are not immediately updated or destroyed when you make a change to the master map. Instead, there's a time-to-live set which tells everyone that you expect the master map to be valid for X seconds:

Time to live - Wikipedia, the free encyclopedia



Why am i still able to see erors: /http://intodns.com/domain.nl
Probably because the DNS zone was deleted when you terminated the account or edited so it's not working properly. You'll need to verify that the DNS Zone for domain.nl in WHM is complete and also has A records for ns01,ns02,and ns03.

$ dig -t A domain.nl @ns1.domain.nl

; <<>> DiG 9.8.3-P1 <<>> -t A domain.nl @ns1.domain.nl
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 60444
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;domain.nl. IN A

;; Query time: 171 msec
;; SERVER: 149.210.xxx.xxx#53(149.210.xxx.xxx)
;; WHEN: Sun Nov 10 08:16:50 2013
;; MSG SIZE rcvd: 26

Here's a decent book on DNS and Bind that you may want to pick up to have a better understanding of how DNS works and how to troubleshoot it:

DNS and BIND (5th Edition): Cricket Liu, Paul Albitz: 9780596100575: Amazon.com: Books
 

Galanthus

Well-Known Member
Nov 8, 2013
87
0
6
cPanel Access Level
Root Administrator
DNS Nameserver settings - Please help me to finish my server!

Hi there,

I have this problem i have configured my WHM server like 95%. I finished everything changed settings, installed CSF and perfectly working but in order to finish my server i need to finish my DNS settings.

I created yesterday custom nameservers for my website and it is working perfect including subdomains.

But there is a problem in the DNS info please take a look at the screenshots from my WHM, Hosting company and DNS records.

dns.png

DNS2.png

DNS3.png

TransIP settings DNS:
DNS4.png

I would be VERY happy if somebody can tell me what i have to change so i can finish my server.

Thanks guys!!!
 

quietFinn

Well-Known Member
Feb 4, 2006
1,329
141
193
Finland
cPanel Access Level
Root Administrator
Re: DNS Nameserver settings - Please help me to finish my server!

You already asked this same thing in another thread.
DO NOT post the same question(s) in more than one thread.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Re: DNS Nameserver settings - Please help me to finish my server!

But there is a problem in the DNS info please take a look at the screenshots from my WHM, Hosting company and DNS records
It looks like your NS2 IP address used at the registrar may no be responding to DNS requests. Have you checked to ensure that IP address is added to the server and is responding to connection requests?

Thank you.