The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel supports HTTP v. 2 ?

Discussion in 'General Discussion' started by postcd, Aug 22, 2015.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    623
    Likes Received:
    6
    Trophy Points:
    18
  2. eva2000

    eva2000 Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    322
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Brisbane, Australia
    cPanel Access Level:
    Root Administrator
    Twitter:
    Only way for WHM/Cpanel HTTP/2 support right now is if you use LiteSpeed web server plugin for cpanel and use LiteSpeed 5.x which has HTTP/2 support
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's not implemented with cPanel through EasyApache at this time, but feel free to submit a feature request for it via:

    Submit A Feature Request

    In the meantime, you can utilize a third-party web server such as LiteSpeed for this functionality.

    Thank you.
     
  4. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    65
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    We don't have any plans for getting it working in EA3, but it shouldn't be to terribly to get it working with some manual work. We do want to offer http2 support in EA4 in the future, but there aren't any plans in place yet.
     
  5. luigidelgado

    luigidelgado Well-Known Member

    Joined:
    Nov 6, 2010
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    16
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello. I see this post is old. But as of today that Apache has bring it as native of V. 2.4.17+ is http/2 still not supported under cPanel? An interface to configure it?

    Edit: grammatical errors
     
    #5 luigidelgado, Dec 7, 2015
    Last edited: Dec 7, 2015
  6. cPJacob

    cPJacob cPanel Product Owner
    Staff Member

    Joined:
    May 2, 2014
    Messages:
    509
    Likes Received:
    65
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Apache 2.4.17 broke a lot of stuff, so we reverted to 2.4.16. Apache devs are working on getting out 2.4.18 this week I believe. Once this is released, you will be able to build http2 support on your own with EA3.
     
  7. luigidelgado

    luigidelgado Well-Known Member

    Joined:
    Nov 6, 2010
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    16
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    Twitter:
    Great to know Jacob.
     
Loading...

Share This Page