The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel System Redirects Not Working

Discussion in 'General Discussion' started by Xyrael, Mar 31, 2006.

  1. Xyrael

    Xyrael Member

    Joined:
    Oct 10, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Stuff like /whm, /cpanel and /cgi-sys are totally broken on my server and produce annoying 404 errors. The only recent changes I've done is adding a NameVirtualHost directive to httpd.conf after cPanel totally messed it up when adding an account. Can anyone help me? Thanks:)
     
  2. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Check the following entry in your apache conf. If it is not there paste it and then restart apache.

    ScriptAlias /cgi-sys/ /usr/local/cpanel/cgi-sys/
    Alias /sys_cpanel/ /usr/local/cpanel/sys_cpanel/
    Alias /java-sys/ /usr/local/cpanel/java-sys/
    Alias /img-sys/ /usr/local/cpanel/img-sys/
    Alias /akopia/ /usr/local/cpanel/3rdparty/interchange/share/akopia/
    Alias /neo-images/ /usr/local/cpanel/base/neomail/neo-images/
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/kpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /controlpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /securecontrolpanel /usr/local/cpanel/cgi-sys/sredirect.cgi
    Alias /mailman/archives/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    ScriptAlias /mailman/ /usr/local/cpanel/3rdparty/mailman/cgi-bin/
    Alias /pipermail/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    Alias /interchange/ /usr/local/cpanel/3rdparty/interchange/share/interchange/
    Alias /interchange-5/ /usr/local/cpanel/3rdparty/interchange/share/interchange-5/
     
  3. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    First check whether httpd service is running on your server. Execute the below command and try to access WHM and cPanel.
    service httpd restart

    If that doesn't help, try the script :-
    /scripts/upcp --force

    Let us know if you receive any more errors.
     
  4. xidica

    xidica Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Texas
    bijo is correct here....
     
  5. Xyrael

    Xyrael Member

    Joined:
    Oct 10, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Thanks everyone; I didn't reply because I forgot to add thread subscription.

    I'm very grateful for your help :) :)
     
Loading...

Share This Page