The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel/Tmp

Discussion in 'General Discussion' started by Reion, Mar 29, 2006.

  1. Reion

    Reion Member

    Joined:
    Mar 22, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Right we have a prob,
    How do you make the tmp folder 'excutable' with cPanel installed?
    We need it so that we can install Game Servers, at the moment we have to wait for darren to make a zip of the installed files, we are doing it on a server with cPanel installed which changed it to 'non-excutable' and we dont know how to change it back.

    1.Is it possible
    2.If so how?
    :( :(

    Please help....
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Setting execute permissions on /tmp is a very bad idea from the security perspective. Try to consider alternatives before reducing security.

    If something you need seems to require /tmp to be executable, what this really means that that something needs a commonly executable directory and thinks that /tmp will do. If you can, set it to use a different directory.
     
  3. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Indeed. webignition is right on target about security threat when chmod /tmp directory to 755. If you insist, the answer to your 1st question is yes, it is possible; run this command at the prompt:
    chmod 755 /tmp
     
  4. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    No, I think he means, the fact that cPanel 'mounts' the tmp directory as noexec,nosuid etc

    It depends on how the server was originally setup though.

    Try removing the securetmp directive from rc.local and rebooting.
    BUT After you have installed the game, re-enable it. I am assuming you need it executable JUST for the install?
     
  5. Reion

    Reion Member

    Joined:
    Mar 22, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Yep

    Yer once we have done it we will put it back on.

    Also why would chmod 775 help it just stops the server from accessing the tmp folder all together:s
    --------------------------------
    Right we did what you said removed the line and re-booted but, we now think the tmp is too small,
    do any of you know how to make a .sh installl using another folder??
     
    #5 Reion, Mar 29, 2006
    Last edited: Mar 29, 2006
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Probably the simplest thing to do (you're right setting the permissions on the directory won't make a blind bit of difference in this regard) is to mount the cPanel created /tmp partition without noexec on it not that you've removed it from rc.local. You can do this by editing /etc/fstab and adding the line:

    /usr/tmpDSK /tmp ext3 loop,defaults 1 0

    Then:

    mount -a
     
  7. Reion

    Reion Member

    Joined:
    Mar 22, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Dw

    Dont worry we got it working we found a code that tells the installer to use a tmp dir we made ourself and it worked fine.

    Thanks anyway!!;) ;)
     
Loading...

Share This Page