The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel to gmail and back again

Discussion in 'E-mail Discussions' started by spiff06, Jan 15, 2005.

  1. spiff06

    spiff06 Well-Known Member

    Joined:
    Jan 17, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    I have a cPanel server (my.server).
    root messages from my.server are sent to a gmail account (me @ gmail.com).
    I set a gmail filter to send messages coming from root @ my.server to user @ domain.com.
    domain.com happens to live on my.server.

    A basic chaining to make sure I receive root mail in all cases.

    However, root mail re-sent through the gmail filter bounces off:

    If I try to forward the message from gmail manually, no problem:

    but autoforwarders have started failing around the turn of the year.

    I *think* this may be caused by the presence of +caf_user=domain.com in the forwarded mail, but previous messages did not seem to have a problem with it. Is there a way to test whether exim indeed does choke on these (admittedly odd) characters in the sender tag? What else could cause the bounce?

    Thanks,
    Eric
     
  2. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    Just some basic things to check up on...

    SPF on or too restrictive?

    Sender Verify enabled?
     
  3. spiff06

    spiff06 Well-Known Member

    Joined:
    Jan 17, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Dropped the ball on this one and coming back to it again now that I have a little more time. Since I haven't resolved the issue yet, I guess that counts as a *BUMP*.

    It seems the _caf is normal: it stands for (Something)AutoForward.

    I'm using APF, but it isn't blocking gmail's server (64.223.184.195).

    Sender verify is obviously on (but I used to be able to receive mails with
    it turned on).
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The problem is really in the error. It suggests the problem is with the way gmail is forwarding email since "me+caf_user=domain.com@gmail.com" is not a valid email sender, the sender check fails. Gmail is breaking the rules on mail forwarding by: 1. modifying the email header and 2. doing so with incorrect data - that is not the sender address.

    Two choices:

    1. Disable Sender checks (totally, or hack exim.conf for your domain only).

    2. Report the broken nature of gmail's forwarding to them and gon't use gmail until they fix it.
     
  5. spiff06

    spiff06 Well-Known Member

    Joined:
    Jan 17, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    The email format is odd indeed.

    As far as sender existence checks, isn't it somewhat safer to leave them on?

    For now, I can try ticking off the box and see what happens...

    Thanks,
    Eric
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Absolutely - I'd not disable Sender checking. It guess it just depends how much you want to use the gmail method of forwarding off and back on server.
     
  7. spiff06

    spiff06 Well-Known Member

    Joined:
    Jan 17, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Well, I suppose I can use a different account to store those messages.

    Just wondering: how difficult would it be to tweak exim to accept a particular mail addressing format, and do so exclusively for mail originating from the gmail server?

    Just thinking aloud here; don't want to encourage anarchy in mail addressing... ;-)
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  9. spiff06

    spiff06 Well-Known Member

    Joined:
    Jan 17, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Cool, thanks for the link. :)
     
  10. gallot

    gallot Active Member

    Joined:
    Oct 24, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I also experience this as reported on one account in my server. They are not receiving mails from one domain which happens to be an important contact. I looked into the mail log and found out the following:

    2007-01-31 05:11:23 1HCDNT-0005ID-0p H=(mail.senderdomain.com) [xxx.xxx.xxx.xxx] F=<name@senderdomain.com> temporarily rejected after DATA: all attempts to verify a sender in a header line deferred

    Good citizen Chirpy mentioned that either

    Disable Sender checks (totally, or hack exim.conf for your domain only)

    I am interested in the second option. AS I understand, the second option entails editing exim.conf to accomodate senderdomain.com or bypass senderdomain.com from cPanel's Sender Check.

    Any info on which particular line in exim.conf this will be done? It will highly be appreciated.
     
  11. gallot

    gallot Active Member

    Joined:
    Oct 24, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    Since I am getting desperate on this, I disabled/uncheck

    Verify the existence of email senders.

    in WHM under Exim Cofiguration Editor and still the error from an account sending to the server:

    2007-01-31 05:11:23 1HCDNT-0005ID-0p H=(mail.senderdomain.com) [xxx.xxx.xxx.xxx] F=<name@senderdomain.com> temporarily rejected after DATA: all attempts to verify a sender in a header line deferred

    Any idea on this please?
     
  12. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    I'm not sure whether this will help or not, but I'm curious whether changing the sender from gmail may help. You can go into Gmail's Settings -> Accounts and change the default sending account. That just possibly might be enough to get you past the exim checks you're having problems with - then again, it might not help. Worth a stab though.
     
Loading...

Share This Page