The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel, Trustix + Bind

Discussion in 'Bind / DNS / Nameserver Issues' started by mattonline, Nov 5, 2004.

  1. mattonline

    mattonline Member

    Joined:
    Sep 27, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone, I have read all the posts on this issue but have found nothing to assist me.

    I'm running cPanel on Trustix 2.0 - the issue is that BIND is never up, when you restart it I get the following error message:

    named has failed, please contact the sysadmin (result was "named is not running"). Nov 6 13:08:21 mayo named: Named is not running failed Nov 6 13:08:21 mayo named[2236]: starting BIND 9.2.2 -u named -t /var/lib/named/chroot -c /etc/named.conf Nov 6 13:08:21 mayo named[2236]: using 1 CPU Nov 6 13:08:21 mayo named: named startup succeeded Nov 6 13:08:21 mayo named[2236]: loading configuration from '/etc/named.conf' Nov 6 13:08:21 mayo named[2236]: /etc/named.conf:100: '}' expected near end of file Nov 6 13:08:21 mayo named[2236]: loading configuration: unexpected token Nov 6 13:08:21 mayo named[2236]: exiting (due to fatal error)

    I've tried running /scripts/fixbuggynamed, /scripts/fixnamed, /scripts/rebuildnamedconf etc all without success.

    The other issue is that after a few days of the server being up I have multiple instances (so far the most I've seen is 50) of this running (as shown in service status) :

    Disk /var/spool/sysklog.d/dev (/var/lib/named/chroot/dev) 2%

    After a reboot two of these instances appear but many more are added as the machine is on for a period of time, any ideas?

    Thanks

    Matt

    Yes, I have lodged a ticket with cPanel - #79521
     
    #1 mattonline, Nov 5, 2004
    Last edited: Nov 5, 2004
Loading...

Share This Page