The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel Update crashed box

Discussion in 'General Discussion' started by cyexx, Oct 7, 2006.

  1. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    I have a FreeBSD 5.4-STABLE #0 Thu Aug 11 20:53 box running had an uptime of about 3 months and everything was going fine until cpanel ran the new update for stable, for some reason upcp removed the shared linux lib files in /usr/lib that are required for cpanel.whm.cppop and other things to run and because of such core dumped the machine into a reboot, i have re-linked the lib files and tried restarting but the same problem happens where apache, exim, cppop, whm, ftp, mysql will not come back up, the only way to get them to come back online is to manual restart the services, and the only way to get whm back online is to force a /scripts/upcp --force command

    the cpanel mainlog is empty, everytime i try to start cpanel from the cli i get command not found for "service start cpanel" and restartsrc_cpanel does not exist on the system

    any idea's
     
  2. chillitech

    chillitech Registered

    Joined:
    Jan 13, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    try "service cpanel restart"

    my cpanel box wont go into cpanel after last nights update, i still have whm working though.. just trying a "/scripts/upcp --force" now and it seems to hang after it updates the scripts
    :(
     
  3. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Code:
    [root@alpha /scripts]# service cpanel restart
    -bash: service: command not found
    [root@alpha /scripts]#

    Also getting this issue

    Code:
    [root@alpha /scripts]# /scripts/restartsrv_spamd
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    [root@alpha /scripts]#

    and this one as well looks like same perl issue from cpanel
    Code:
    [root@alpha /scripts]# /scripts/restartsrv_spamd
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    [root@alpha /scripts]#
    [root@alpha /scripts]# /scripts/restartsrv_eximstats
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LC_ALL = (unset),
            LANG = "en_US"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    [root@alpha /scripts]#
    
     
  4. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    same problem here.

    10.8.2-STABLE_120

    cppop stopped working last night unexpectedly. That was resolved by restarting cPanel I believe.

    Now I have users saying a few of their joomla/wordpress installs are throwing 500 internal server errors. Ran /scripts/upcp, and MySQL stops working completely. Restarting cPanel resolved the issue.

    And people wonder why some are nervous when it comes to running upcp - even on "STABLE" releases.

    edit: restarting cPanel did in fact not resolve this. what the hell cPanel
     
  5. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    tail -f in the /var/lib/mysql/hostname.err while running /etc/rc.d/init.d/mysql start:


    edit: /var/lib/mysql/mysql/host.MYI does exist, and has the same perms/ownership as other servers.


    edit2: found my answer here for anyone experiencing something similiar lately: http://forums.cpanel.net/showthread.php?p=244726
    SupermanInNY's post did the trick
     
    #5 randomuser, Oct 8, 2006
    Last edited: Oct 8, 2006
  6. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You're using FreeBSD which is a little different than other Linux distributions.

    The problem here is that locale is not set correctly. To fix it, run the following command:

    setenv LC_ALL "C"
    setenv LANG "en_US"


    When done, run the following commands:
    /scripts/rpmup
    /scripts/sysup
    /scripts/upcp --force
     
  7. cyexx

    cyexx Well-Known Member

    Joined:
    Sep 3, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    finally got it fixed it was a layer of problem for some reason upcp thought my freebsd box was a linux box and had changed all the linkers and had removed perl and cpan
     
Loading...

Share This Page