Cpanel update error from scripts/rpmup

Operating System & Version
CLOUDLINUX 7.8
cPanel & WHM Version
v86.0.21

chofmeister

Registered
May 23, 2020
2
0
1
Orlando, Florida
cPanel Access Level
DataCenter Provider
Hi all. We recently upgrade our cpanel server to cloudlinux and the nightly script it ran (scripts/rpmup) recently generated some errors.

[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] --> Running transaction check
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] ---> Package libreport-centos.x86_64 0:2.1.11-53.el7.centos will be obsoleted
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: libreport-centos >= 2.1.11-46 for package: abrt-cli-2.1.11-57.el7.centos.x86_64
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] ---> Package libreport-plugin-mantisbt.x86_64 0:2.1.11-53.el7.centos will be obsoleted
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] --> Processing Dependency: libreport-plugin-mantisbt >= 2.1.11-46 for package: abrt-cli-2.1.11-57.el7.centos.x86_64
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] ---> Package subscription-manager-rhsm-certificates.x86_64 0:1.24.26-1.el7 will be installed
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] --> Finished Dependency Resolution
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] Error: Package: abrt-cli-2.1.11-57.el7.centos.x86_64 (@base)
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] Error: Package: abrt-cli-2.1.11-57.el7.centos.x86_64 (@base)
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] You could try using --skip-broken to work around the problem
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] You could try running: rpm -Va --nofiles --nodigest
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] :
[2020-05-23 01:01:26 -0400] [/usr/local/cpanel/scripts/rpmup] checkyum version 22.3 (excludes: bind-chroot ruby)
[2020-05-23 01:01:26 -0400] E [/usr/local/cpanel/scripts/rpmup] The “/usr/local/cpanel/scripts/rpmup” command (process 2006224) reported error number 1 when it ended.
[2020-05-23 01:01:26 -0400] The Administrator will be notified to review this output when this script completes
[2020-05-23 01:01:26 -0400] - Finished command `/usr/local/cpanel/scripts/rpmup` in 71.380 seconds
[2020-05-23 01:01:26 -0400] 30% complete
[2020-05-23 01:01:26 -0400] - Finished in 71.381 seconds
[2020-05-23 01:01:26 -0400] - Finished in 0.057 seconds
[2020-05-23 01:01:26 -0400] Processing:
[2020-05-23 01:01:26 -0400] Maintenance complete



The error that stands out is of course Error: Package: abrt-cli-2.1.11-57.el7.centos.x86_64 (@base)

Not sure how to fix this unless the package is no longer needed and can safely be removed.
I tried the recommend rpm -Va --nofiles --nodigest it ran a for a few minutes but showed no output when it completed.
I have not tried doing the other recommended --skip-broken

I also checked access rights to the /etc folder and seems fine to me.

[[email protected] ~]# lsattr -d /etc
---------------- /etc
[[email protected] ~]# stat /etc
File: ‘/etc’
Size: 12288 Blocks: 32 IO Block: 4096 directory
Device: 803h/2051d Inode: 536870977 Links: 112
Access: (0755/drwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2020-05-23 12:57:51.557491764 -0400
Modify: 2020-05-23 12:50:00.855609396 -0400
Change: 2020-05-23 12:50:00.855609396 -0400
Birth: -


Any ideas would be appreciated thank you.
 

cPSamuelM

Technical Analyst Team Lead
Staff member
Nov 20, 2019
196
38
103
USA
cPanel Access Level
Root Administrator
Hello @chofmeister

Thank you for contacting cPanel! It seems as though there might be some relevant details missing from the portion of the log file you shared with us. There might be a dependency solving issue that is detailed earlier in the log file.

Can you please let us know the results of the following commands?

Code:
cat /etc/redhat-release

rpm -qa |grep abrt-cli

grep -C5 abrt-cli /var/cpanel/updatelogs/last
I look forward to your reply!
 
  • Like
Reactions: cmyer