Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cpanel update failed

Discussion in 'General Discussion' started by Dany Barahona, Jun 17, 2015.

  1. Dany Barahona

    Dany Barahona Registered

    Joined:
    Jun 17, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Grettings

    My cpanel update failed
    can't do a ticket because can't obtain support access id
    whm show this message
    "cPanel & WHM Update in Progress
    This functionality is not available until the cPanel update is complete.
    Once the update is completed, you will no longer see this message. If the update has completed since loading this page, click here to reload."

    Via ssh show this error:

    /usr/local/cpanel/cpanel -S
    DBD::SQLite object version 1.42 does not match $DBD::SQLite::VERSION 1.46.
    Segmentation fault (core dumped)

    Please help me

    The logs from my update are:
    Code:
    [2015-06-17 09:28:10 -0300] W Exit Code: 254
    [2015-06-17 09:28:10 -0300] ***** FATAL: Test install failed:   package cpanel-php54-5.4.31-3.cp1150.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Translation-2.2.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Date-2.0.13-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Auth-2.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Url-2.2.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Text-Filter-2.1.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Serialize-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package MySQL56-client-5.6.23-3.cp1148.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Tree-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Compress-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-Filter-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Mail-2.1.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Injector-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-1.3.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Text-Flowed-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Mime-Viewer-2.0.5-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-ListHeaders-1.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Argv-2.0.7-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-ElasticSearch-1.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-HashTable-1.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-Wrapper-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Support-2.1.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Icalendar-2.0.10-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Data-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Image-2.0.5-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Db-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-content-2.0.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-History-2.2.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Date-Parser-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Timezone-1.0.9-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Lock-2.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Kolab-Session-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Routes-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Xml-Element-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-perl-514-Mail-SpamAssassin-3.004000-4.cp1146.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package exim-4.85-6.cp1148.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Cli-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-SessionHandler-2.2.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Smtp-1.2.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Crypt-Blowfish-1.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Constraint-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Oauth-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]   The Administrator will be notified to review this output when this script completes
    [2015-06-17 09:28:10 -0300] ***** FATAL: Error testing if the RPMs will install: Test install failed:   package cpanel-php54-5.4.31-3.cp1150.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Translation-2.2.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Date-2.0.13-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Auth-2.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Url-2.2.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Text-Filter-2.1.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Serialize-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package MySQL56-client-5.6.23-3.cp1148.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Tree-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Compress-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-Filter-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Mail-2.1.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Injector-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-1.3.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Text-Flowed-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Mime-Viewer-2.0.5-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-ListHeaders-1.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Argv-2.0.7-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-ElasticSearch-1.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-HashTable-1.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Stream-Wrapper-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Support-2.1.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Icalendar-2.0.10-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Data-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Image-2.0.5-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Db-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-content-2.0.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-History-2.2.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Date-Parser-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Timezone-1.0.9-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Lock-2.1.0-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Kolab-Session-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Routes-2.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Xml-Element-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-perl-514-Mail-SpamAssassin-3.004000-4.cp1146.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package exim-4.85-6.cp1148.x86_64 is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Cli-2.0.4-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-SessionHandler-2.2.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Smtp-1.2.3-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Crypt-Blowfish-1.0.2-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Constraint-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]     package cpanel-php54-Horde-Oauth-2.0.1-1.cp1150.noarch is already installed
    [2015-06-17 09:28:10 -0300]   see http://go.cpanel.net/rpmcheckfailed for more information
    [2015-06-17 09:28:10 -0300]   The Administrator will be notified to review this output when this script completes
    => Log closed Wed Jun 17 09:28:10 2015
    [2015-06-17 09:28:10 -0300]   17% complete
    [2015-06-17 09:28:10 -0300] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1434543966.log --force` failed, exited with code 1 (signal = 0)
    => Log closed Wed Jun 17 09:28:11 2015
    
    
     
  2. Felipe Augusto Barreto

    Joined:
    Jun 17, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I solved the problem with this commands:
    /usr/local/cpanel/scripts/check_cpanel_rpms --fix
    /scripts/autorepair fix_duplicate_cpanel_rpms
     
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,827
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Please let us know if the commands referenced in the previous post address this issue on your system.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Dany Barahona

    Dany Barahona Registered

    Joined:
    Jun 17, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Hello
    my issue continue because the second command crush my system

    cant generate a ticket because this command failed

    /usr/local/cpanel/cpanel -S
    DBD::SQLite object version 1.42 does not match $DBD::SQLite::VERSION 1.46.
    Segmentation fault (core dumped)

    Please help me
     
  5. Dany Barahona

    Dany Barahona Registered

    Joined:
    Jun 17, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    issue resolved
    Problem was a partition blocked. When cpanel try update, the system crashed.

    Thx :)
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,827
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice