The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel Update Failing

Discussion in 'General Discussion' started by constarr, Apr 7, 2010.

  1. constarr

    constarr Registered

    Joined:
    Apr 7, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Whenever I try to update cpanel/whm to the current version it freezes up on the "Updating FTP Server information" part. let me know waht is causing this please.. Would like to get rid of the errors in cPanel. I have restarted the server to make sure there were no other lingering processes as well

    Code:
    Updating FTP Server...Ftp Setup Script Version 6.1
    Fetching version information from http://httpupdate.cpanel.net/ftpinstall/version (STABLE)....Fetching http://httpupdate.cpanel.net/ftpinstall/version (0)....@72.233.42.250......connected......receiving...100%......Done
    Done
    This is the pure-ftpd 1.0.27 installer release number 1.tls for platform centos 5.4
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * addons: centos.mirrors.tds.net
     * base: mirrors.gigenet.com
     * extras: mirrors.netdna.com
     * updates: holmes.umflint.edu
    Excluding Packages in global exclude list
    Finished
    Setting up Install Process
    No package libdb3.3-devel available.
    Package db4-devel-4.3.29-10.el5.x86_64 already installed and latest version
    Package db4-devel-4.3.29-10.el5.i386 already installed and latest version
    Package compat-db-4.2.52-5.1.x86_64 already installed and latest version
    Package compat-db-4.2.52-5.1.i386 already installed and latest version
    Package zlib-devel-1.2.3-3.x86_64 already installed and latest version
    Package zlib-devel-1.2.3-3.i386 already installed and latest version
    Package rpm-build-4.4.2.3-18.el5.x86_64 already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    --> Processing Dependency: gcc = 4.1.2-46.el5_4.1 for package: gcc-c++
    ---> Package gcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    --> Processing Dependency: cpp = 4.1.2-46.el5_4.2 for package: gcc
    --> Processing Dependency: libgcc >= 4.1.2-46.el5_4.2 for package: gcc
    ---> Package glibc-devel.i386 0:2.5-42.el5_4.3 set to be updated
    --> Processing Dependency: glibc = 2.5-42.el5_4.3 for package: glibc-devel
    --> Processing Dependency: glibc-headers = 2.5-42.el5_4.3 for package: glibc-devel
    ---> Package glibc-devel.x86_64 0:2.5-42.el5_4.3 set to be updated
    ---> Package openssl.i686 0:0.9.8e-12.el5_4.6 set to be updated
    ---> Package openssl.x86_64 0:0.9.8e-12.el5_4.6 set to be updated
    ---> Package openssl-devel.i386 0:0.9.8e-12.el5_4.6 set to be updated
    ---> Package openssl-devel.x86_64 0:0.9.8e-12.el5_4.6 set to be updated
    ---> Package pam-devel.i386 0:0.99.6.2-6.el5_4.1 set to be updated
    --> Processing Dependency: pam = 0.99.6.2-6.el5_4.1 for package: pam-devel
    ---> Package pam-devel.x86_64 0:0.99.6.2-6.el5_4.1 set to be updated
    --> Running transaction check
    ---> Package cpp.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package gcc-c++.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    --> Processing Dependency: libstdc++ = 4.1.2-46.el5_4.2 for package: gcc-c++
    --> Processing Dependency: libstdc++-devel = 4.1.2-46.el5_4.2 for package: gcc-c++
    --> Processing Dependency: glibc = 2.5-42 for package: nscd
    ---> Package glibc.i686 0:2.5-42.el5_4.3 set to be updated
    --> Processing Dependency: glibc-common = 2.5-42.el5_4.3 for package: glibc
    ---> Package glibc.x86_64 0:2.5-42.el5_4.3 set to be updated
    ---> Package glibc-headers.x86_64 0:2.5-42.el5_4.3 set to be updated
    ---> Package libgcc.i386 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package libgcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package pam.i386 0:0.99.6.2-6.el5_4.1 set to be updated
    ---> Package pam.x86_64 0:0.99.6.2-6.el5_4.1 set to be updated
    --> Running transaction check
    ---> Package glibc-common.x86_64 0:2.5-42.el5_4.3 set to be updated
    ---> Package libstdc++.i386 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package libstdc++.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package libstdc++-devel.i386 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package libstdc++-devel.x86_64 0:4.1.2-46.el5_4.2 set to be updated
    ---> Package nscd.x86_64 0:2.5-42.el5_4.3 set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ================================================================================
     Package              Arch        Version                    Repository    Size
    ================================================================================
    Updating:
     gcc                  x86_64      4.1.2-46.el5_4.2           updates      5.3 M
     glibc-devel          i386        2.5-42.el5_4.3             updates      2.0 M
     glibc-devel          x86_64      2.5-42.el5_4.3             updates      2.4 M
     openssl              i686        0.9.8e-12.el5_4.6          updates      1.4 M
     openssl              x86_64      0.9.8e-12.el5_4.6          updates      1.4 M
     openssl-devel        i386        0.9.8e-12.el5_4.6          updates      1.9 M
     openssl-devel        x86_64      0.9.8e-12.el5_4.6          updates      1.9 M
     pam-devel            i386        0.99.6.2-6.el5_4.1         updates      187 k
     pam-devel            x86_64      0.99.6.2-6.el5_4.1         updates      187 k
    Updating for dependencies:
     cpp                  x86_64      4.1.2-46.el5_4.2           updates      2.9 M
     gcc-c++              x86_64      4.1.2-46.el5_4.2           updates      3.8 M
     glibc                i686        2.5-42.el5_4.3             updates      5.2 M
     glibc                x86_64      2.5-42.el5_4.3             updates      4.7 M
     glibc-common         x86_64      2.5-42.el5_4.3             updates       16 M
     glibc-headers        x86_64      2.5-42.el5_4.3             updates      591 k
     libgcc               i386        4.1.2-46.el5_4.2           updates       95 k
     libgcc               x86_64      4.1.2-46.el5_4.2           updates       97 k
     libstdc++            i386        4.1.2-46.el5_4.2           updates      361 k
     libstdc++            x86_64      4.1.2-46.el5_4.2           updates      352 k
     libstdc++-devel      i386        4.1.2-46.el5_4.2           updates      2.8 M
     libstdc++-devel      x86_64      4.1.2-46.el5_4.2           updates      2.8 M
     nscd                 x86_64      2.5-42.el5_4.3             updates      165 k
     pam                  i386        0.99.6.2-6.el5_4.1         updates      976 k
     pam                  x86_64      0.99.6.2-6.el5_4.1         updates      976 k
    
    Transaction Summary
    ================================================================================
    Install      0 Package(s)         
    Update      24 Package(s)         
    Remove       0 Package(s)         
    
    Total size: 59 M
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    memory alloc (24 bytes) returned NULL.
    Resetting pure-ftpd to cPanel Defaults and Installing the Latest Version
    Fetching http://diff.cpanel.net/ftpinstall/pure-ftpd/64/centos/5.4/pure-ftpd-1.0.27-1.tls.x86_64.rpm (0)....@72.233.42.250......connected......receiving...28%...56%...84%...100%......Done
    Preparing...                ##################################################
    pure-ftpd                   #warning: /etc/pure-ftpd.conf created as /etc/pure-ftpd.conf.rpmnew
    #################################################
    
     
  2. constarr

    constarr Registered

    Joined:
    Apr 7, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Fixed myself. Updated yum and it seems to work fine.
     
  3. chuza

    chuza Well-Known Member

    Joined:
    Jul 4, 2008
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I am getting the same error 'No package libdb3.3-devel available.' What in yum did you fix that resolved it for you.
    Second, is it safe to run 'yum update' on a vps. What to add in exclude list.

     
  4. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Yes, it is! VPS is just the same as dedicated where all that goes ...

    Cpanel will already of added the items you need excluded in /etc/yum.conf

    If you are running a virtuozzo based VPS (Eww yuck by the way :rolleyes:)
    then I would also additionally add an exclusion for kernel updates.

    A personal preference, I usually put "wget*" in the exclusion list and then download and compile the source from Gnu as it is somewhat newer than the releases includes with RedHat and CentOS.

    One slight variation on your "yum update" command. Instead of running that as you wrote it, try the following instead:

    Code:
    # yum -y upgrade
    Yum doesn't ask you for confirmations and also picks up minor components to be upgraded to full update the system that way.
     
Loading...

Share This Page