The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel update failure during updatenow -11.34.1.7 to 11.36.0.2

Discussion in 'General Discussion' started by Lenfitz, Jan 29, 2013.

  1. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    An error was detected which prevented updatenow from completing normally.
    Please review the enclosed log for further details

    ----------------------------------------------------------------------------------------------------

    Code:
    [20130130.083004]   Detected version '11.34.1.7' from version file.
    [20130130.083004]   Target version set to '11.36.0.2'
    [20130130.083004]   Checking license
    [20130130.083004]   License file check complete
    [20130130.083004]   Checking that the RPM DB is OK...
    [20130130.083004]   glibc-2.5-81.el5_8.7
    [20130130.083004]   glibc-2.5-81.el5_8.7
    [20130130.083004]   OK: RPM DB is responding to queries
    [20130130.083004]   Testing if rpm_is_working RPM is installed
    [20130130.083004]   package rpm_is_working is not installed
    [20130130.083004]   Testing if it's possible to install a simple RPM
    [20130130.083004]   Preparing...                ##################################################
    [20130130.083004]   rpm_is_working              ##################################################
    [20130130.083004]   Switching to version '11.36.0.2' of updatenow to perform sync.
    [20130130.083006]   Loaded plugins: fastestmirror
    [20130130.083006]   Loading mirror speeds from cached hostfile
    [20130130.083006]    * epel: fedora-epel.mirror.lstn.net
    [20130130.083006]   Excluding Packages in global exclude list
    [20130130.083008]   Finished
    [20130130.083008]   Setting up Install Process
    [20130130.083009]   Package vixie-cron is obsoleted by crond, trying to install crond-5.14-1h.1.x86_64 instead
    [20130130.083009]   Package crond-5.14-1h.1.x86_64 already installed and latest version
    [20130130.083009]   Nothing to do
    [20130130.083010] E Sysup: Needed system RPMs were not installed: vixie-cron [20130130.083010] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130130.083010]   The Administrator will be notified to review this output when this script completes
    [20130130.083010] E Detected events which require user notification during updatenow. Will send iContact the log
    Also,

    Cpanel update failure in upcp,

    Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1359495004.log` failed, exited with code 4608

    Auto updates have been successful in the past with no server changes for quite a while except 1H Hive software installed which i'm hoping is irrelevant to the above issue.

    What do I need to do to fix this please?

    Cheers
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The update is blocking on the inability to install the vixie-cron package. Which operating system, and version, are you using?
     
  4. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    CENTOS 5.8 x86_64
    Linux 2.6.18-238.9.1.el5 x86_64

    - - - Updated - - -

    The server attempted to update version to Target version set to '11.36.0.3' (instead of 11.36.02) and reported...

    An error was detected which prevented updatenow from completing normally.
    Please review the enclosed log for further details

    ----------------------------------------------------------------------------------------------------

    Code:
    [20130131.020103]   Detected version '11.34.1.7' from version file.
    [20130131.020103]   Target version set to '11.36.0.3'
    [20130131.020103]   Checking license
    [20130131.020103]   License file check complete
    [20130131.020103]   Checking that the RPM DB is OK...
    [20130131.020104]   glibc-2.5-81.el5_8.7
    [20130131.020104]   glibc-2.5-81.el5_8.7
    [20130131.020104]   OK: RPM DB is responding to queries
    [20130131.020104]   Testing if rpm_is_working RPM is installed
    [20130131.020104]   package rpm_is_working is not installed
    [20130131.020104]   Testing if it's possible to install a simple RPM
    [20130131.020104]   Preparing...                ##################################################
    [20130131.020104]   rpm_is_working              ##################################################
    [20130131.020105]   Switching to version '11.36.0.3' of updatenow to perform sync.
    [20130131.020106]   Loaded plugins: fastestmirror
    [20130131.020106]   Loading mirror speeds from cached hostfile
    [20130131.020106]    * epel: fedora-epel.mirror.lstn.net
    [20130131.020106]   Excluding Packages in global exclude list
    [20130131.020108]   Finished
    [20130131.020108]   Setting up Install Process
    [20130131.020109]   Package vixie-cron is obsoleted by crond, trying to install crond-5.14-1h.1.x86_64 instead
    [20130131.020109]   Package crond-5.14-1h.1.x86_64 already installed and latest version
    [20130131.020109]   Nothing to do
    [20130131.020110] E Sysup: Needed system RPMs were not installed: vixie-cron [20130131.020110] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130131.020110]   The Administrator will be notified to review this output when this script completes
    [20130131.020110] E Detected events which require user notification during updatenow. Will send iContact the log
     
  5. pixelwerx

    pixelwerx Member

    Joined:
    Jan 16, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I've been experiencing the same issue since January 29. Any ideas?

    System info:
    CENTOS 5.9 i686 standard
    ConfigServer Firewall

    Code:
    [20130131.123320] 0% complete [20130131.123320] Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.) [20130131.123320] 1% complete ----------------------------------------------------------------------------------------------------
    => Log opened from /scripts/upcp at Thu Jan 31 12:33:20 2013
    [20130131.123320]   Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.)
    => Log closed Thu Jan 31 12:33:20 2013
    [20130131.123320]   Running Standardized hooks
    [20130131.123320]   mtime on upcp is 1355207272 (Tue Dec 11 00:27:52 2012)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow at Thu Jan 31 12:33:20 2013
    [20130131.123320]   Detected version '11.34.1.7' from version file.
    [20130131.123320]   Target version set to '11.36.0.3'
    [20130131.123320]   Switching to 11.36.0.3 to determine if we can reach that version without failure.
    [20130131.123320]   Retrieving /cpanelsync/11.36.0.3/cpanel/scripts/updatenow.static.bz2
    [20130131.123320]   Using mirror: 209.188.92.54
    => Log closed Thu Jan 31 12:33:20 2013
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static at Thu Jan 31 12:33:21 2013
    [20130131.123321]   Detected version '11.34.1.7' from version file.
    [20130131.123321]   Target version set to '11.36.0.3'
    [20130131.123321]   Checking license
    [20130131.123326]   License file check complete
    [20130131.123326]   Checking that the RPM DB is OK...
    [20130131.123326]   glibc-2.5-107
    [20130131.123326]   OK: RPM DB is responding to queries
    [20130131.123326]   Testing if rpm_is_working RPM is installed
    [20130131.123326]   package rpm_is_working is not installed
    [20130131.123326]   Testing if it's possible to install a simple RPM
    [20130131.123326]   Preparing...                ##################################################
    [20130131.123326]   rpm_is_working              ##################################################
    [20130131.123326]   Switching to version '11.36.0.3' of updatenow to perform sync.
    [20130131.123330]   Loaded plugins: fastestmirror
    [20130131.123330]   Loading mirror speeds from cached hostfile
    [20130131.123331]    * base: centos.corenetworks.net
    [20130131.123331]    * epel: mirror.es.its.nyu.edu
    [20130131.123331]    * extras: yum.singlehop.com
    [20130131.123331]    * updates: centos-mirror.jchost.net
    [20130131.123331]   Excluding Packages in global exclude list
    [20130131.123334]   Finished
    [20130131.123334]   Setting up Install Process
    [20130131.123334]   No package wget available.
    [20130131.123335]   Nothing to do
    [20130131.123339] E Sysup: Needed system RPMs were not installed: wget
    [20130131.123339] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130131.123339]   The Administrator will be notified to review this output when this script completes
    [20130131.123339] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Thu Jan 31 12:33:39 2013
    [20130131.123339] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1359657200.log` failed, exited with code 4608
    => Log closed Thu Jan 31 12:33:39 2013
    
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    A required RPM, wget, is apparently excluded in your yum.conf file. This may be a result of installing Fantastico on your system (I'm speculating as to the cause). To upgrade you will need to allow wget to be managed by yum.
     
  7. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    An error was detected which prevented updatenow from completing normally.
    Please review the enclosed log for further details

    ----------------------------------------------------------------------------------------------------

    [20130202.020102] Detected version '11.34.1.7' from version file.
    [20130202.020102] Target version set to '11.36.0.4'
    [20130202.020102] Checking license
    [20130202.020102] License file check complete
    [20130202.020102] Checking that the RPM DB is OK...
    [20130202.020102] glibc-2.5-81.el5_8.7
    [20130202.020102] glibc-2.5-81.el5_8.7
    [20130202.020102] OK: RPM DB is responding to queries
    [20130202.020102] Testing if rpm_is_working RPM is installed
    [20130202.020102] package rpm_is_working is not installed
    [20130202.020102] Testing if it's possible to install a simple RPM
    [20130202.020102] Preparing... ##################################################
    [20130202.020102] rpm_is_working ##################################################
    [20130202.020102] Switching to version '11.36.0.4' of updatenow to perform sync.
    [20130202.020108] Loaded plugins: fastestmirror
    [20130202.020108] Loading mirror speeds from cached hostfile
    [20130202.020109] * epel: mirror.utexas.edu
    [20130202.020109] Excluding Packages in global exclude list
    [20130202.020111] Finished
    [20130202.020111] Setting up Install Process
    [20130202.020112] Package vixie-cron is obsoleted by crond, trying to install crond-5.14-1h.1.x86_64 instead
    [20130202.020112] Package crond-5.14-1h.1.x86_64 already installed and latest version
    [20130202.020112] Nothing to do
    [20130202.020114] E Sysup: Needed system RPMs were not installed: vixie-cron [20130202.020114] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130202.020114] The Administrator will be notified to review this output when this script completes
    [20130202.020114] E Detected events which require user notification during updatenow. Will send iContact the log


    So how do I fix this vixie-cron issue please ?
     
  8. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    We have case 63336 filed regarding the vixie-cron issue. At this time I don't have enough information to provide a work around.
     
  9. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Ken. I'll sit tight for now.
     
  10. pixelwerx

    pixelwerx Member

    Joined:
    Jan 16, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi Ken,

    Sure enough wget* was excluded in yum.conf. Fixed! However I'm seeing a different problem as the cPanel tries to complete the upgrade:

    Code:
    [20130205.104442]   Staging new RPMS
    [20130205.104446]   Downloading /rpm.md5
    [20130205.104447] ***** FATAL: Could not download '/rpm.md5' to '/usr/local/cpanel/tmp/rpm_downloads/.md5' at /usr/local/cpanel/scripts/updatenow.static line 12245.
    [20130205.104447]   The Administrator will be notified to review this output when this script completes
    [20130205.104447] E Error staging RPM files: Could not download '/rpm.md5' to '/usr/local/cpanel/tmp/rpm_downloads/.md5' at /usr/local/cpanel/scripts/updatenow.static line 12245.
    [20130205.104447]       ...propagated at /usr/local/cpanel/scripts/updatenow.static line 12251.
    [20130205.104447] E Detected events which require user notification during updatenow. Will send iContact the log
    
    When the procedure is finished I get this message although cPanel still displays WHM 11.34.1 (build 7):

    Code:
    ----------------------------------------------------------------------------------------------------
    => Log opened from cPanel Update (upcp) - Slave at Tue Feb  5 10:51:22 2013
    [20130205.105122]   Maintenance completed successfully
    [20130205.105122]   Couldn't run try-later; maybe atd isn't working?
    [20130205.105122]   Running Standardized hooks
    [20130205.105122]   
    [20130205.105122]  cPanel update completed
    [20130205.105122]   A log of this update is available at /var/cpanel/updatelogs/update.1360082580.log
    [20130205.105122]   Removing upcp pidfile
    [20130205.105122]   
    [20130205.105122] Completed all updates
    => Log closed Tue Feb  5 10:51:22 2013
    
    
    Upgrade Complete
    Print the contents of this window 
    
    Just to verify, Release Tier is set to Current on this server.
     
  11. SamVimes777

    SamVimes777 Registered

    Joined:
    Feb 9, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi

    I have a some issue. Little bit different of yours cases. I have one vps with cPanel, when start update from 11.34 to 11.36, update faild with following errors:
    Code:
    VPS running on CloudLinux Server release 6.3 64-bit.

    So how do I fix this issue please?
     
  12. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I'm not sure about the last two errors posted in this thread. I recommend you open support tickets with us at https://tickets.cpanel.net (if you haven't already opened a ticket).
     
  13. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    G'day Ken,

    Just wondering if there has been any update with this case? It's 4 versions later and nothing has changed my end. I have had to turn off auto updates and a manual update still returns the same error.

    Cheers
     
  14. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    From the cPanel & WHM 11.36 Change Log :

     
  15. Lenfitz

    Lenfitz Member

    Joined:
    Jun 1, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Thank you guys.

    I can happily report back the server successfully upgraded to WHM 11.36.0 (build 9) without a hitch.

    Much appreciated and thank you once again.
     
  16. LBJ

    LBJ Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    G'day Pixelwerx,

    We're hitting the same "FATAL: Could not download '/rpm.md5'" update issue on 2 of our servers. The others are fine. Did you find a solution to this?

    We have a ticket in the process, but so far no reply has come our way.
     
  17. LBJ

    LBJ Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Further to my posting above, we sorted our 2 affected servers and performed a clean upgrade.

    For anyone else who hits this, just ensure all perl modules are up to date prior to running upcp.
     
Loading...

Share This Page