The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel update failure

Discussion in 'General Discussion' started by milcman, Mar 21, 2013.

  1. milcman

    milcman Registered

    Joined:
    Nov 3, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    can anyone point me in the right direction on how to address the cpanel update failure I am getting? Thank you,

    [20130322.124813] OK: RPM DB is responding to queries
    [20130322.124813] Testing if rpm_is_working RPM is installed
    [20130322.124813] package rpm_is_working is not installed
    [20130322.124813] Testing if it's possible to install a simple RPM
    [20130322.124813] Preparing... ##################################################
    [20130322.124813] rpm_is_working ##################################################
    [20130322.124814] Switching to version '11.36.0.14' of updatenow to perform sync.
    [20130322.124817] Loaded plugins: fastestmirror
    [20130322.124817] Determining fastest mirrors
    [20130322.124818] Error: Cannot find a valid baseurl for repo: addons
    [20130322.124818] YumRepo Error: All mirror URLs are not using ftp, http or file.
    [20130322.124818] Eg. 1.3.5 is not a valid release or hasnt been released yet/
    [20130322.124818] removing mirrorlist with no valid mirrors: /var/cache/yum/addons/mirrorlist.txt
    [20130322.124818] Prelinking is disabled.
    [20130322.124819] E Sysup: Needed system RPMs were not installed: at, curl-devel, ghostscript, glib, lcms, libaio, libaio-devel, libwmf
    [20130322.124819] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130322.124819] The Administrator will be notified to review this output when this script completes
    [20130322.124819] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Fri Mar 22 12:48:19 2013
    [20130322.124819] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1363916892.log` failed, exited with code 4608
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please ensure that your system package manager (YUM) is able to successfully update. EX:

    Code:
    # yum update
    Do you receive any errors when updating or installing packages with YUM?

    Thank you.
     
  3. milcman

    milcman Registered

    Joined:
    Nov 3, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thanks...

    No I was not able to do a yum update. Had basically the same error as above.

    I had logged it with my VPS provider and the issue has now been sorted.

    It turns out that there was a 2nd instance of the glibc files installed on the VPS. The duplicate file was removed and now the cpanel update is working fine.

    Not sure how/why there was a 2nd instance but appears all is working again,

    Thank you.
     
  4. musioc

    musioc Well-Known Member

    Joined:
    Aug 4, 2011
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Hello, We have the same problem for updating cpanel from 11.34 to 11.36

    Error:

    Code:
    root@server [~]# /scripts/upcp
    [20130406.183214]   Detected cron=0 (Terminal detected)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /scripts/upcp at Sat Apr  6 18:32:14 2013
    [20130406.183214]   Detected cron=0 (Terminal detected)
    => Log closed Sat Apr  6 18:32:14 2013
    [20130406.183214]   Running Standardized hooks
    [20130406.183214]   mtime on upcp is 1355798483 (Tue Dec 18 07:11:23 2012)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow at Sat Apr  6 18:32:14 2013
    [20130406.183214]   Detected version '11.34.1.13' from version file.
    [20130406.183214]   Target version set to '11.36.0.20'
    [20130406.183214]   Switching to 11.36.0.20 to determine if we can reach that version without failure.
    [20130406.183214]   Retrieving /cpanelsync/11.36.0.20/cpanel/scripts/updatenow.static.bz2
    [20130406.183214]   Using mirror: 159.253.142.50
    => Log closed Sat Apr  6 18:32:14 2013
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static at Sat Apr  6 18:32:14 2013
    [20130406.183214]   Detected version '11.34.1.13' from version file.
    [20130406.183214]   Target version set to '11.36.0.20'
    [20130406.183214]   Checking license
    [20130406.183214]   License file check complete
    [20130406.183214]   Checking that the RPM DB is OK...
    [20130406.183214]   glibc-2.12-1.107.el6.x86_64
    [20130406.183214]   OK: RPM DB is responding to queries
    [20130406.183214]   Testing if rpm_is_working RPM is installed
    [20130406.183214]   package rpm_is_working is not installed
    [20130406.183214]   Testing if it's possible to install a simple RPM
    [20130406.183214]   Preparing...                ##################################################
    [20130406.183214]   rpm_is_working              ##################################################
    [20130406.183214]   Switching to version '11.36.0.20' of updatenow to perform sync.
    [20130406.183215]   Loaded plugins: fastestmirror, rhnplugin
    [20130406.183216]   Loading mirror speeds from cached hostfile
    [20130406.183222]    * cloudlinux-x86_64-server-6: de-proxy.cl-mirror.net
    [20130406.183222]    * rpmforge: mirror.de.leaseweb.net
    [20130406.183222]   Setting up Install Process
    [20130406.183222]   Resolving Dependencies
    [20130406.183222]   --> Running transaction check
    [20130406.183222]   ---> Package at.x86_64 0:3.1.10-43.el6_2.1 will be installed
    [20130406.183222]   ---> Package hunspell.x86_64 0:1.2.8-16.el6 will be installed
    [20130406.183222]   ---> Package hunspell-en.noarch 0:0.20090216-7.1.el6 will be installed
    [20130406.183222]   ---> Package lcms.x86_64 0:1.19-1.el6 will be installed
    [20130406.183222]   ---> Package libaio-devel.x86_64 0:0.3.107-10.el6 will be installed
    [20130406.183222]   --> Processing Dependency: libaio = 0.3.107-10.el6 for package: libaio-devel-0.3.107-10.el6.x86_64
    [20130406.183224]   ---> Package libwmf.x86_64 0:0.2.8.4-22.el6 will be installed
    [20130406.183224]   ---> Package pcre-devel.x86_64 0:7.8-6.el6 will be installed
    [20130406.183224]   --> Running transaction check
    [20130406.183224]   ---> Package libaio.i686 0:0.3.107-10.el6 will be installed
    [20130406.183224]   --> Finished Dependency Resolution
    [20130406.183224]   Error:  Multilib version problems found. This often means that the root
    [20130406.183224]          cause is something else and multilib version checking is just
    [20130406.183224]          pointing out that there is a problem. Eg.:
    [20130406.183224]
    [20130406.183224]            1. You have an upgrade for libaio which is missing some
    [20130406.183224]               dependency that another package requires. Yum is trying to
    [20130406.183224]               solve this by installing an older version of libaio of the
    [20130406.183224]               different architecture. If you exclude the bad architecture
    [20130406.183224]               yum will tell you what the root cause is (which package
    [20130406.183224]               requires what). You can try redoing the upgrade with
    [20130406.183224]               --exclude libaio.otherarch ... this should give you an error
    [20130406.183224]               message showing the root cause of the problem.
    [20130406.183224]
    [20130406.183224]            2. You have multiple architectures of libaio installed, but
    [20130406.183224]               yum can only see an upgrade for one of those arcitectures.
    [20130406.183224]               If you don't want/need both architectures anymore then you
    [20130406.183224]               can remove the one with the missing update and everything
    [20130406.183224]               will work.
    [20130406.183224]
    [20130406.183224]            3. You have duplicate versions of libaio installed already.
    [20130406.183224]               You can use "yum check" to get yum show these errors.
    [20130406.183224]
    [20130406.183224]          ...you can also use --setopt=protected_multilib=false to remove
    [20130406.183224]          this checking, however this is almost never the correct thing to
    [20130406.183224]          do as something else is very likely to go wrong (often causing
    [20130406.183224]          much more problems).
    [20130406.183224]
    [20130406.183224]          Protected multilib versions: libaio-0.3.107-10.el6.i686 != libaio-0.3.109-2.fc13.x86_64
    [20130406.183224]    You could try using --skip-broken to work around the problem
    [20130406.183224]   ** Found 13 pre-existing rpmdb problem(s), 'yum check' output follows:
    [20130406.183224]   audit-libs-2.2-2.el6.x86_64 is a duplicate with audit-libs-2.1.3-3.el6.x86_64
    [20130406.183224]   bandmin-1.6.1-5.noarch has missing requires of perl(bandmin.conf)
    [20130406.183224]   bandmin-1.6.1-5.noarch has missing requires of perl(bmversion.pl)
    [20130406.183224]   bandmin-1.6.1-5.noarch has missing requires of perl(services.conf)
    [20130406.183224]   chkconfig-1.3.49.3-2.el6.x86_64 is a duplicate with chkconfig-1.3.49.3-1.el6_2.x86_64
    [20130406.183224]   exim-4.80-5.x86_64 has missing requires of perl(SafeFile)
    [20130406.183224]   expat-2.0.1-11.el6_2.x86_64 is a duplicate with expat-2.0.1-9.1.el6.x86_64
    [20130406.183224]   gawk-3.1.7-10.el6.x86_64 is a duplicate with gawk-3.1.7-9.el6.x86_64
    [20130406.183224]   glib2-2.22.5-7.el6.x86_64 is a duplicate with glib2-2.22.5-6.el6.x86_64
    [20130406.183224]   keyutils-libs-1.4-4.el6.x86_64 is a duplicate with keyutils-libs-1.4-3.el6.x86_64
    [20130406.183224]   libselinux-2.0.94-5.3.el6.x86_64 is a duplicate with libselinux-2.0.94-5.2.el6.x86_64
    [20130406.183224]   readline-6.0-4.el6.x86_64 is a duplicate with readline-6.0-3.el6.x86_64
    [20130406.183224]   sed-4.2.1-10.el6.x86_64 is a duplicate with sed-4.2.1-7.el6.x86_64
    [20130406.183224]   Prelinking is disabled.
    [20130406.183225] E Sysup: Needed system RPMs were not installed: at, hunspell, hunspell-en, lcms, libaio-devel, libwmf, pcre-devel
    [20130406.183225] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20130406.183225]   The Administrator will be notified to review this output when this script completes
    [20130406.183225] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Sat Apr  6 18:32:25 2013
    [20130406.183225] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1365256934.log` failed, exited with code 4608
    => Log closed Sat Apr  6 18:32:25 2013
    root@server [~]#


    yum.conf exclude list :

    update error :
    there is no error while yum update!

    Other servers with same configuration was updated without any problem
     
  5. musioc

    musioc Well-Known Member

    Joined:
    Aug 4, 2011
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    please see this part of error :
     
  6. musioc

    musioc Well-Known Member

    Joined:
    Aug 4, 2011
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    problem solved with manually installing and removing these rpms
    hunspell, hunspell-en, lcms, libaio-devel, libwmf, pcre-devel
    specially libiao
     
  7. jsnape

    jsnape Well-Known Member

    Joined:
    Mar 11, 2002
    Messages:
    174
    Likes Received:
    0
    Trophy Points:
    16
    Kind of an old thread but found it due to the same problem. Fixed by disabling a repo recently installed by cpanel itself after installing postgresql :

    [pgdg84]
    name=PostgreSQL 8.4 $releasever - $basearch
    baseurl=http://yum.pgsqlrpms.org/8.4/redhat/rhel-$releasever-$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG

    [pgdg84-source]
    name=PostgreSQL 8.4 $releasever - $basearch - Source
    failovermethod=priority
    baseurl=http://yum.pgsqlrpms.org/srpms/8.4/redhat/rhel-$releasever-$basearch
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG

    ---
    Changed the 1 to a 0 in the first one.
     
Loading...

Share This Page