The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel update failure

Discussion in 'General Discussion' started by garytip13, Jul 9, 2015.

  1. garytip13

    garytip13 Registered

    Joined:
    Oct 2, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My cpanel install is encountering a problem running an update from 11.48.4.4 to 11.50.0.2

    It appears to be related to updating the x3 theme.

    Code:
    => Log opened from cPanel Update (upcp) - Slave (13183) at Fri Jul 10 03:42:57 2015
    [20150710.034257]   Detected cron=0 (manual flag passed on command line)
    [20150710.034257]   Running Standardized hooks
    [20150710.034257]   mtime on upcp is 1423528339 (Tue Feb 10 03:32:19 2015)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow (13185) at Fri Jul 10 03:42:58 2015
    [20150710.034258]   Detected version '11.48.4.4' from version file.
    [20150710.034258]   Running version '11.48.4.4' of updatenow.
    [20150710.034258]   Using mirror '69.73.140.17' for host 'httpupdate.cpanel.net'.
    [20150710.034258]   Target version set to '11.50.0.23'
    [20150710.034258]   Switching to 11.50.0.23 to determine if we can reach that version without failure.
    [20150710.034258]   Retrieving and staging /cpanelsync/11.50.0.23/cpanel/scripts/updatenow.static.bz2
    [20150710.034258]   Using mirror '69.73.140.17' for host 'httpupdate.cpanel.net'.
    [20150710.034259]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    [20150710.034259]   Become an updatenow.static for version: 11.50.0.23
    => Log closed Fri Jul 10 03:42:59 2015
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync (13185) at Fri Jul 10 03:43:00 2015
    [2015-07-10 03:43:00 +0400]   Detected version '11.48.4.4' from version file.
    [2015-07-10 03:43:00 +0400]   Running version '11.50.0.23' of updatenow.
    [2015-07-10 03:43:00 +0400]   Using mirror '69.73.140.17' for host 'httpupdate.cpanel.net'.
    [2015-07-10 03:43:00 +0400]   Target version set to '11.50.0.23'
    [2015-07-10 03:43:00 +0400]   Checking license
    [2015-07-10 03:43:00 +0400]   License file check complete
    [2015-07-10 03:43:00 +0400]   Checking that the RPM DB is OK...
    [2015-07-10 03:43:01 +0400]   glibc-2.12-1.149.el6_6.9.i686
    [2015-07-10 03:43:01 +0400]   OK: RPM DB is responding to queries
    [2015-07-10 03:43:01 +0400]   Testing if rpm_is_working RPM is installed
    [2015-07-10 03:43:01 +0400]   package rpm_is_working is not installed
    [2015-07-10 03:43:01 +0400]   Testing if it's possible to install a simple RPM
    [2015-07-10 03:43:01 +0400]   Preparing...                ##################################################
    [2015-07-10 03:43:01 +0400]   rpm_is_working              ##################################################
    [2015-07-10 03:43:02 +0400]   Switching to version '11.50.0.23' of updatenow to perform sync.
    [2015-07-10 03:43:03 +0400]   All Needed RPMS are installed.
    [2015-07-10 03:43:03 +0400]   Staging 11.50.0.23 cpanelsync files prior to updating /usr/local/cpanel
    [2015-07-10 03:43:03 +0400]   Staging x3 theme changes
    [2015-07-10 03:43:03 +0400]   Retrieving and staging /cpanelsync/11.50.0.23/x3/.cpanelsync.bz2
    [2015-07-10 03:43:03 +0400]   Using mirror '69.73.140.17' for host 'httpupdate.cpanel.net'.
    [2015-07-10 03:43:04 +0400] E The install encountered a fatal error: Failed to stage x3 theme changes
    [2015-07-10 03:43:04 +0400]   Removing staged files and directories for x3
    => Log closed Fri Jul 10 03:43:04 2015
    [20150710.034305] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1436485377.log` failed, exited with code 10 (signal = 0)
    => Log closed Fri Jul 10 03:43:05 2015
    I have tried and still same error
    Code:
     yum reinstall coreutils
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please post the output from the following command:

    Code:
    stat /usr/bin/sha512sum
    Thank you.
     
Loading...

Share This Page