marjwyatt

Well-Known Member
Jun 23, 2014
50
6
58
cPanel Access Level
Reseller Owner
Overnight, a notification was sent with the preface, "Maintenance ended; however, it did not exit cleanly (256). The following events were logged: “scripts/mainipcheck”.

I've made no changes on the server and all accounts and email seem to be functioning fine.

Here are the relevant entries in the log.

Code:
[2021-01-09 23:33:27 -0800] E [/usr/local/cpanel/scripts/mainipcheck] Encountered an error while determining the main IP from the myip server (https://myip.cpanel.net/v1.0/):
[2021-01-09 23:33:27 -0800] E [/usr/local/cpanel/scripts/mainipcheck] 599 Internal Exception
[2021-01-09 23:33:27 -0800] E [/usr/local/cpanel/scripts/mainipcheck] The “/usr/local/cpanel/scripts/mainipcheck” command (process 28315) reported error number 11 when it ended.
When I execute "/usr/local/cpanel/scripts/mainipcheck" from the command line, nothing is returned. I looked over IP settings on WHM and everything appears to be in order.

Should I be concerned about this and, if so, can you give me some advice about troubleshooting and remedy?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
3,236
404
243
cPanel Access Level
Root Administrator
Since we make an external call back to our network at that point of the update process, if there was a temporary network issue it may also have triggered that error. If the command is working well now, I would also expect a new "/scripts/upcp --force" run to work properly.
 
  • Like
Reactions: marjwyatt

marjwyatt

Well-Known Member
Jun 23, 2014
50
6
58
cPanel Access Level
Reseller Owner
Have you tried rerunning "/scripts/upcp" again to see if it finishes without any error this time?
Thank you for your help. I ran that script after I saw your reply in email. It did complete without errors.

Nothing in the notification gave a hint that this was the script to run. I'm a "fledgling" admin learning as I go, so that the email was all that I had to go with.
 
  • Like
Reactions: wintech2003