cpanel update installed SpamAssassin 3.0 - messed things up!

MediaHound

Active Member
May 1, 2004
26
0
151
Florida
Message from my server admin:
Part of the autoupdate installed Spamassassin 3.0 which was just released this week. I'm
not sure what it has done specificially but something in the cooperation between exim,
MailScanner and Spamassassin broke and this prevents mails from being processed and
delivered.

In order to get mail flowing I've modified your MailScanner configuration to *not* use
SpamAssassin for the time being, and it seems mail is being processed now.

Anyone else notice problems?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,453
31
473
Go on, have a guess
Your server admin should look a little deeper and do some work to investigate the issue more.

It's not rocket science and I'm not going to post all the possible permutations, but if they do the following they can then start fixing the problems:

spamassassin --lint -c /usr/mailscanner/etc/spam.assassin.prefs.conf
 

mr.wonderful

BANNED
Feb 1, 2004
345
1
166
chirpy said:
Your server admin should look a little deeper and do some work to investigate the issue more.

It's not rocket science and I'm not going to post all the possible permutations, but if they do the following they can then start fixing the problems:

spamassassin --lint -c /usr/mailscanner/etc/spam.assassin.prefs.conf
That path is dependant on where the prefs file is located. Not everyone has spam.assassin.prefs.conf installed in the above directory.
 

nickn

Well-Known Member
PartnerNOC
Jun 15, 2003
617
1
168
For what it's worth, cPanel did not update to SA3, CentOS 3.3 upgraded spamassassin to SA3.
 

DigitalN

Well-Known Member
Sep 23, 2004
419
1
168
nickn said:
For what it's worth, cPanel did not update to SA3, CentOS 3.3 upgraded spamassassin to SA3.
# cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)
# /usr/bin/spamassassin -V
SpamAssassin version 3.0.0
running on Perl version 5.8.1

It would appear not to be just restricted to Centos, /scripts/rpmup will install version 3.0.0 at least on Redhat 9 too.
 
C

cPanelBilly

Guest
cPanel had nothing to do with the update, it was caused by CPAN updating.
We are currently working on a patch to fix this error.
 

cretu

Well-Known Member
Jul 21, 2002
208
0
166
SA 3.0 does not rewrite subjects with cPanel - will this be fixed too?

Cretu
 

Crooner

Member
Oct 22, 2002
21
0
151
MediaHound said:
Message from my server admin:
Part of the autoupdate installed Spamassassin 3.0 which was just released this week. I'm
not sure what it has done specificially but something in the cooperation between exim,
MailScanner and Spamassassin broke and this prevents mails from being processed and
delivered.

In order to get mail flowing I've modified your MailScanner configuration to *not* use
SpamAssassin for the time being, and it seems mail is being processed now.

Anyone else notice problems?
We had this problem also - fixed the SpamAssassin config till there were no errors and it still would not allow mail through. The problem is with MailScanner - just update to the latest version (it likes SA 3.0) and make sure your MailScanner.conf file is updated and it will start working.

Dean Martin
 

Scott Greczkows

Well-Known Member
Feb 5, 2004
63
1
158
Anyone know how I can get subject rewriting to work again? Before it was adding **SPAM** to the subject but now its not.

Thanks
 

zim01

Member
Sep 27, 2004
5
0
151
Scott Greczkows said:
Anyone know how I can get subject rewriting to work again? Before it was adding **SPAM** to the subject but now its not.

Thanks
change required_hits to required_score
change your rewrite to rewrite_header Subject ****SPAM(_SCORE_)****