The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED cPanel Update Issue

Discussion in 'General Discussion' started by bdariyes, Dec 11, 2016.

Tags:
  1. bdariyes

    bdariyes Member

    Joined:
    Feb 11, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    KL
    When i am trying to update cPanel from 56 to 60 its always stuck in 17%. Then I try to fix the RPM and run this command in SSH: /scripts/upcp --force i got the following error. can anybody tell me how can i fix it?

    Code:
    016-12-12 04:07:31 +0000]   Retrieving and staging /cpanelsync/11.56.0.39/cpanel/Whostmgr/Transfers/Systems/NobodyFiles.pm.xz
    [2016-12-12 04:07:31 +0000]   Retrieving and staging /cpanelsync/11.56.0.39/cpanel/Cpanel/Security/Advisor/Assessors/Brute.pm.xz
    => Log closed Mon Dec 12 04:07:31 2016
    [2016-12-12 04:07:31 +0000]   Sync child 8562 exited cleanly.
    [2016-12-12 04:07:31 +0000]   Staging new RPMS
    [2016-12-12 04:07:33 +0000]   Downloading http://httpupdate.cpanel.net/RPM/11.56/centos/7/x86_64/rpm.sha512
    [2016-12-12 04:07:33 +0000]   Successfully verified signature for cpanel (key types: release).
    [2016-12-12 04:07:34 +0000]   MySQL55-server-5.5.52-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   bandmin-1.6.1-3.cp1156.noarch.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   MySQL55-shared-5.5.52-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   MySQL55-client-5.5.52-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-perl-522-5.22.1-10.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-perl-522-Cpanel-CORE-Dependencies-1.5-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   MySQL55-devel-5.5.52-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-perl-522-Compress-Raw-Lzma-2.069-2.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-git-2.9.0-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-php54-5.4.31-4.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   cpanel-perl-522-Mail-SPF-v2.9.0-2.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:34 +0000]   MySQL55-test-5.5.52-1.cp1156.x86_64.rpm already downloaded
    [2016-12-12 04:07:35 +0000]   All files Staged
    [2016-12-12 04:07:35 +0000]   Testing if the newly downloaded RPMS can be installed without conflict
    [2016-12-12 04:07:35 +0000]   Testing RPM transaction
    [2016-12-12 04:07:37 +0000]   error: Failed dependencies:
    [2016-12-12 04:07:37 +0000]     MySQL55-server is obsoleted by (installed) MySQL56-server-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-shared is obsoleted by (installed) MySQL56-shared-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-client is obsoleted by (installed) MySQL56-client-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-devel is obsoleted by (installed) MySQL56-devel-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-test is obsoleted by (installed) MySQL56-test-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000] W Exit Code: 12
    [2016-12-12 04:07:37 +0000] ***** FATAL: Test install failed: error: Failed dependencies:
    [2016-12-12 04:07:37 +0000]     MySQL55-server is obsoleted by (installed) MySQL56-server-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-shared is obsoleted by (installed) MySQL56-shared-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-client is obsoleted by (installed) MySQL56-client-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-devel is obsoleted by (installed) MySQL56-devel-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-test is obsoleted by (installed) MySQL56-test-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]   The Administrator will be notified to review this output when this script completes
    [2016-12-12 04:07:37 +0000] ***** FATAL: Error testing if the RPMs will install: Test install failed: error: Failed dependencies:
    [2016-12-12 04:07:37 +0000]     MySQL55-server is obsoleted by (installed) MySQL56-server-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-shared is obsoleted by (installed) MySQL56-shared-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-client is obsoleted by (installed) MySQL56-client-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-devel is obsoleted by (installed) MySQL56-devel-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]     MySQL55-test is obsoleted by (installed) MySQL56-test-5.6.30-1.cp1156.x86_64
    [2016-12-12 04:07:37 +0000]   see https://go.cpanel.net/rpmcheckfailed for more information
    [2016-12-12 04:07:37 +0000]   The Administrator will be notified to review this output when this script completes
    => Log closed Mon Dec 12 04:07:37 2016
    [2016-12-12 04:07:37 +0000]   17% complete
    [2016-12-12 04:07:37 +0000] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1481515546.log --force` failed, exited with code 1 (signal = 0)
    => Log closed Mon Dec 12 04:07:37 2016
    => Log closed Mon Dec 12 04:07:37 2016
    Regards
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post the output from the following commands on the affected system:

    Code:
    cat /etc/redhat-release
    grep mysql-version /var/cpanel/cpanel.config
    rpm -qa|grep MySQL
    cat /etc/systemd/system/mysql.service
    cat /var/cpanel/rpm.versions.d/cloudlinux.versions
    Note that last command is only applicable if you have installed CloudLinux.

    Thank you.
     
  3. bdariyes

    bdariyes Member

    Joined:
    Feb 11, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    KL
    thanks for quick reply. The outputs are below:

    Code:
    cat /etc/redhat-release
    CentOS Linux release 7.2.1511 (Core) 
    Code:
    grep mysql-version /var/cpanel/cpanel.config
    mysql-version=5.5
    Code:
    rpm -qa|grep MySQL
    compat-MySQL50-shared-5.0.96-4.cp1136.x86_64
    cpanel-perl-522-MySQL-Diff-0.43-1.cp1156.x86_64
    MySQL56-test-5.6.30-1.cp1156.x86_64
    MySQL56-server-5.6.30-1.cp1156.x86_64
    MySQL56-client-5.6.30-1.cp1156.x86_64
    compat-MySQL51-shared-5.1.73-1.cp1150.x86_64
    MySQL56-shared-5.6.30-1.cp1156.x86_64
    MySQL56-devel-5.6.30-1.cp1156.x86_64
    Code:
    cat /etc/systemd/system/mysql.service
    [Unit]
    Description=MySQL Server
    ConditionPathExists=!/etc/mysqldisable
    
    [Service]
    Type=simple
    ExecStart=/usr/bin/mysqld_safe
    User=mysql
    Group=mysql
    WorkingDirectory=/usr
    LimitNOFILE=65536
    
    [Install]
    WantedBy=multi-user.target
    And i dont have Cloud linux installed.

    regards
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Edit this file and replace this value with:

    Code:
    mysql-version=5.6
    This will match the installed RPMs on your system. Then, run the following commands:

    Code:
    /scripts/update_local_rpm_versions --edit target_settings.MySQL55 uninstalled
    /scripts/update_local_rpm_versions --edit target_settings.MySQL56 installed
    /scripts/check_cpanel_rpms --fix
    Let us know if this helps to address the issue.

    Thank you.
     
  5. bdariyes

    bdariyes Member

    Joined:
    Feb 11, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    KL
    At first thanks, I have edit the cpanel.config file. But when i run this command I got an error. I try to fix it by reading several forum post but still its giving same error. Any suggestion?

    Code:
    /scripts/update_local_rpm_versions --edit target_settings.MySQL55 uninstalled
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "UTF-8",
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
    Kind regards
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    The command should have still completed successfully, despite that warning message. The warning message is unrelated, and discussed on the following third-party URL:

    How to fix a locale setting warning from Perl?

    Thanks!
     
  7. bdariyes

    bdariyes Member

    Joined:
    Feb 11, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    51
    Location:
    KL
    Thanks for your help, The Problem was solved. I just need to restart the server and try your commands.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    36,995
    Likes Received:
    1,275
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page