Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED cPanel update script failure

Discussion in 'General Discussion' started by 4est, Nov 30, 2017.

Tags:
  1. 4est

    4est Member

    Joined:
    Jul 13, 2017
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Brasov, RO
    cPanel Access Level:
    Root Administrator
    I get some errors when updating php54, php55 and php56


    Code:
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php54 …
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]     Error: (XID p966hx) 9 errors occurred:
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #1: “pfpro.defaulttimeout” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #2: “pfpro.defaulthost” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #3: “ifx.default_password” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #4: “ifx.byteasvarchar” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #5: “ifx.default_host” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #6: “ifx.textasvarchar” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #7: “ifx.default_user” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #8: “ifx.charasvarchar” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #9: “ifx.max_persistent” is not a valid directive for PHP version “5.4.45”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]  … done!
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php55 …
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]     Error: (XID takwmx) 9 errors occurred:
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #1: “ifx.nullformat” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #2: “ifx.blobinfile” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #3: “ifx.max_links” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #4: “ifx.allow_persistent” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #5: “pfpro.defaultport” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #6: “ifx.max_persistent” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #7: “ifx.charasvarchar” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #8: “ifx.default_user” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #9: “ifx.textasvarchar” is not a valid directive for PHP version “5.5.38”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]  … done!
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php56 …
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]     Error: (XID 3hyq9b) 9 errors occurred:
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #1: “ifx.default_host” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #2: “ifx.byteasvarchar” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #3: “ifx.default_password” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #4: “pfpro.defaulttimeout” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #5: “pfpro.defaulthost” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #6: “ifx.nullformat” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #7: “ifx.allow_persistent” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #8: “pfpro.defaultport” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]         Error #9: “ifx.max_links” is not a valid directive for PHP version “5.6.32”.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]  … done!
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php70 …
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]     No local.ini.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]  … done!
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini] Processing ea-php71 …
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]     No local.ini.
    [2017-11-26 21:30:35 +0200]      [/usr/local/cpanel/scripts/migrate_local_ini_to_php_ini]  … done!

    at the end:

    [2017-11-26 21:30:36 +0200] E Pre Maintenance ended, however it did not exit cleanly (256). Please check the logs for an indication of what happened



    If I run
    /scripts/migrate_local_ini_to_php_ini --run --verbose
    I get this, sorry it's hard to understand


    Code:
    Processing ea-php54 â¦
            Ignoring invalid directive âpfpro.defaultportâ
            ifx.charasvarcharâ
            ifx.max_linksâ
            pfpro.defaulthostâ
            ifx.max_persistentâ
    
                    Error: (XID schg8y) 9 errors occurred:
                    Error #1: âifx.nullformatâ5.4.45â
                                                                    Error #2: âifx.textasvarcharâ5.4.45â
                                                                                                                    Error #3: âifx.default_userâ5.4.45â
                                                                                                                                                                    Error #4: âifx.blobinfileâ5.4.45â
                                                                                                                                                                                                                    Error #5: âifx.default_hostâ5.4.45â
                            Error #6: âpfpro.defaulttimeoutâ5.4.45â
                                                                            Error #7: âifx.allow_persistentâ5.4.45â
                                                                                                                            Error #8: âifx.default_passwordâ5.4.45â
                                                                                                                                                                            Error #9: âifx.byteasvarcharâ5.4.45â
                                                                                                                                                                                                                 ⦠done!
    Processing ea-php55 â¦
            Ignoring invalid directive âifx.blobinfileâ
            ifx.default_userâ
            ifx.allow_persistentâ
            pfpro.defaulttimeoutâ
            ifx.default_hostâ
    
                    Error: (XID yam45y) 9 errors occurred:
                    Error #1: âifx.max_linksâ5.5.38â
                                                                    Error #2: âifx.max_persistentâ5.5.38â
                                                                                                                    Error #3: âpfpro.defaulthostâ5.5.38â
                                                                                                                                                                    Error #4: âpfpro.defaultportâ5.5.38â
                                                                                                                                                                                                                    Error #5: âifx.charasvarcharâ5.5.38â
                            Error #6: âifx.default_passwordâ5.5.38â
                                                                            Error #7: âifx.byteasvarcharâ5.5.38â
                                                                                                                            Error #8: âifx.nullformatâ5.5.38â
                                                                                                                                                                            Error #9: âifx.textasvarcharâ5.5.38â
                                                                                                                                                                                                                 ⦠done!
    Processing ea-php56 â¦
            Ignoring invalid directive âifx.nullformatâ
            ifx.textasvarcharâ
            ifx.default_userâ
            ifx.blobinfileâ
            ifx.default_hostâ
    
                    Error: (XID dr5m59) 9 errors occurred:
                    Error #1: âifx.default_passwordâ5.6.32â
                                                                    Error #2: âifx.byteasvarcharâ5.6.32â
                                                                                                                    Error #3: âpfpro.defaultportâ5.6.32â
                                                                                                                                                                    Error #4: âifx.charasvarcharâ5.6.32â
                                                                                                                                                                                                                    Error #5: âifx.max_linksâ5.6.32â
                            Error #6: âifx.max_persistentâ5.6.32â
                                                                            Error #7: âpfpro.defaulthostâ5.6.32â
                                                                                                                            Error #8: âpfpro.defaulttimeoutâ5.6.32â
                                                                                                                                                                            Error #9: âifx.allow_persistentâ5.6.32â
                                                                                                                                                                                                                    ⦠done!
    Processing ea-php70 â¦
            No local.ini.
     ⦠done!
    Processing ea-php71 â¦
            No local.ini.
     ⦠done!
     
    #1 4est, Nov 30, 2017
    Last edited by a moderator: Nov 30, 2017
  2. rpvw

    rpvw Well-Known Member

    Joined:
    Jul 18, 2013
    Messages:
    781
    Likes Received:
    275
    Trophy Points:
    113
    Location:
    Spain
    cPanel Access Level:
    Root Administrator
    Your first block of results contained everything that was causing you issues.
    Stripping out the bits that aren't relevant:
    Code:
    Processing ea-php54 …
        Error: (XID p966hx) 9 errors occurred:
            Error #1: “pfpro.defaulttimeout” is not a valid directive for PHP version “5.4.45”.
            Error #2: “pfpro.defaulthost” is not a valid directive for PHP version “5.4.45”.
            Error #3: “ifx.default_password” is not a valid directive for PHP version “5.4.45”.
            Error #4: “ifx.byteasvarchar” is not a valid directive for PHP version “5.4.45”.
            Error #5: “ifx.default_host” is not a valid directive for PHP version “5.4.45”.
            Error #6: “ifx.textasvarchar” is not a valid directive for PHP version “5.4.45”.
            Error #7: “ifx.default_user” is not a valid directive for PHP version “5.4.45”.
            Error #8: “ifx.charasvarchar” is not a valid directive for PHP version “5.4.45”.
            Error #9: “ifx.max_persistent” is not a valid directive for PHP version “5.4.45”.
     … done!
    
    Processing ea-php55 …
        Error: (XID takwmx) 9 errors occurred:
            Error #1: “ifx.nullformat” is not a valid directive for PHP version “5.5.38”.
            Error #2: “ifx.blobinfile” is not a valid directive for PHP version “5.5.38”.
            Error #3: “ifx.max_links” is not a valid directive for PHP version “5.5.38”.
            Error #4: “ifx.allow_persistent” is not a valid directive for PHP version “5.5.38”.
            Error #5: “pfpro.defaultport” is not a valid directive for PHP version “5.5.38”.
            Error #6: “ifx.max_persistent” is not a valid directive for PHP version “5.5.38”.
            Error #7: “ifx.charasvarchar” is not a valid directive for PHP version “5.5.38”.
            Error #8: “ifx.default_user” is not a valid directive for PHP version “5.5.38”.
            Error #9: “ifx.textasvarchar” is not a valid directive for PHP version “5.5.38”.
     … done!
    
    Processing ea-php56 …
        Error: (XID 3hyq9b) 9 errors occurred:
            Error #1: “ifx.default_host” is not a valid directive for PHP version “5.6.32”.
            Error #2: “ifx.byteasvarchar” is not a valid directive for PHP version “5.6.32”.
            Error #3: “ifx.default_password” is not a valid directive for PHP version “5.6.32”.
            Error #4: “pfpro.defaulttimeout” is not a valid directive for PHP version “5.6.32”.
            Error #5: “pfpro.defaulthost” is not a valid directive for PHP version “5.6.32”.
            Error #6: “ifx.nullformat” is not a valid directive for PHP version “5.6.32”.
            Error #7: “ifx.allow_persistent” is not a valid directive for PHP version “5.6.32”.
            Error #8: “pfpro.defaultport” is not a valid directive for PHP version “5.6.32”.
            Error #9: “ifx.max_links” is not a valid directive for PHP version “5.6.32”.
     … done!
    
    Processing ea-php70 …
        No local.ini.
     … done!
    
    Processing ea-php71 …
        No local.ini.
     … done!
    Fix or delete the invalid entries in your local php.ini files, and rerun the /usr/local/cpanel/scripts/migrate_local_ini_to_php_ini script
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    garconcn likes this.
  3. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,753
    Likes Received:
    1,886
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    The information in the previous post should help. Let us know if you have additional questions.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. 4est

    4est Member

    Joined:
    Jul 13, 2017
    Messages:
    17
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Brasov, RO
    cPanel Access Level:
    Root Administrator
    Thank you, Indeed, the error was quite obvious once my post was edited by a moderator :)
    Thanks, problem fixed!
     
    cPanelMichael likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice