The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel Updates changes apache port

Discussion in 'EasyApache' started by thewird, Aug 13, 2007.

  1. thewird

    thewird Well-Known Member

    Joined:
    Jan 4, 2006
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto
    Cpanel updates keeps changing my port setting in "/etc/chkserv.d/httpd" from 82 to 80. How do I make it not do this?

    thewird
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I would recommend that if you wish to monitor port 82 that you duplicate the settings for httpd (to say httpd82) so that the http entries that cPanel/WHM expects to monitor port 80 doesn't affect your monitoring port 82.
     
  3. thewird

    thewird Well-Known Member

    Joined:
    Jan 4, 2006
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto
    I'm not sure I know what you mean? Apache's port is set to 82.

    thewird
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The chkservd monitoring scripts are hard coded for the default ports. The default port for Apache (non-SSL) is 80. Whenever a upcp occurs, the process will note your httpd monitoring script was modified and revert it to the 'correct' value. Changing the port in httpd.conf will not effect the chkservd monitoring script.
     
  5. thewird

    thewird Well-Known Member

    Joined:
    Jan 4, 2006
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Toronto
    I have various servers with squid on port 80 and apache on port 82 configured the same way. Only 2 out of a few servers seem to change occassionally (not all the time).

    thewird
     
Loading...

Share This Page