The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CPanel Upgrade Failed - Needed system RPMs were not installed.

Discussion in 'General Discussion' started by Phil_b, Oct 16, 2013.

  1. Phil_b

    Phil_b Registered

    Joined:
    Aug 4, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    when upgrading CPanel / WHM I receive the following issue and have done for a while now. Ive checked your "Fix RPM Installation Failures in WHM" document and none help. Also I have seen a number of others with this issue. Can someone please advise? Thanks


    Code:
    [20131016.193531] 0% complete [20131016.193531] Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.) [20131016.193531] 1% complete ----------------------------------------------------------------------------------------------------
    => Log opened from /scripts/upcp at Wed Oct 16 19:35:31 2013
    [20131016.193531]   Detected cron=0 (env var CPANEL_IS_CRON was present before this process started.)
    [20131016.193531]   Running Standardized hooks
    => Log closed Wed Oct 16 19:35:31 2013
    [20131016.193531]   mtime on upcp is 1355805331 (Tue Dec 18 04:35:31 2012)
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow at Wed Oct 16 19:35:31 2013
    [20131016.193531]   Detected version '11.34.2.4' from version file.
    [20131016.193531]   Target version set to '11.38.2.7'
    [20131016.193531]   Switching to 11.38.2.7 to determine if we can reach that version without failure.
    [20131016.193531]   Retrieving /cpanelsync/11.38.2.7/cpanel/scripts/updatenow.static.bz2
    [20131016.193531]   Using mirror: 94.75.231.77
    => Log closed Wed Oct 16 19:35:31 2013
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static at Wed Oct 16 19:35:31 2013
    [20131016.193531]   Detected version '11.34.2.4' from version file.
    [20131016.193531]   Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.
    [20131016.193531]   Target version set to '11.38.2.7'
    [20131016.193531]   Checking license
    [20131016.193532]   License file check complete
    [20131016.193532]   Checking that the RPM DB is OK...
    [20131016.193532]   glibc-2.5-107.el5_9.5
    [20131016.193532]   glibc-2.5-107.el5_9.5
    [20131016.193532]   OK: RPM DB is responding to queries
    [20131016.193532]   Testing if rpm_is_working RPM is installed
    [20131016.193532]   package rpm_is_working is not installed
    [20131016.193532]   Testing if it's possible to install a simple RPM
    [20131016.193532]   Preparing...                ##################################################
    [20131016.193532]   rpm_is_working              ##################################################
    [20131016.193532]   Upgrade requested to a version more than 1 LTS away. Will upgrade to next LTS first (11.38.2.7).
    [20131016.193532]   Target version set to '11.36.2.4'
    [20131016.193532]   Switching to version '11.36.2.4' of updatenow to perform sync.
    [20131016.193532]   Retrieving and staging /cpanelsync/11.36.2.4/cpanel/scripts/updatenow.static.bz2
    [20131016.193532]   Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.
    [20131016.193532]   Set permissions on /usr/local/cpanel/scripts/updatenow.static-cpanelsync to 0700
    => Log closed Wed Oct 16 19:35:32 2013
    ----------------------------------------------------------------------------------------------------
    => Log opened from /usr/local/cpanel/scripts/updatenow.static-cpanelsync at Wed Oct 16 19:35:32 2013
    [20131016.193532]   Detected version '11.34.2.4' from version file.
    [20131016.193532]   Target version set to '11.38.2.7'
    [20131016.193532]   Upgrade requested to a version more than 1 LTS away. Will upgrade to next LTS first (11.38.2.7).
    [20131016.193532]   Target version set to '11.36.2.4'
    [20131016.193532]   Switching to version '11.36.2.4' of updatenow to perform sync.
    [20131016.193534]   Loaded plugins: fastestmirror
    [20131016.193534]   Loading mirror speeds from cached hostfile
    [20131016.193534]    * base: mirrors.coreix.net
    [20131016.193534]    * extras: mirrors.coreix.net
    [20131016.193534]    * updates: mirrors.coreix.net
    [20131016.193534]   Excluding Packages in global exclude list
    [20131016.193534]   Finished
    [20131016.193534]   Setting up Install Process
    [20131016.193535]   Resolving Dependencies
    [20131016.193535]   --> Running transaction check
    [20131016.193535]   ---> Package bind-utils.x86_64 30:9.3.6-20.P1.el5_8.6 set to be updated
    [20131016.193535]   ---> Package binutils.x86_64 0:2.17.50.0.6-20.el5_8.3 set to be updated
    [20131016.193535]   ---> Package initscripts.x86_64 0:8.45.42-2.el5.centos.1 set to be updated
    [20131016.193535]   ---> Package shadow-utils.x86_64 2:4.0.17-21.el5 set to be updated
    [20131016.193535]   --> Finished Dependency Resolution
    [20131016.193535]   
    [20131016.193535]   Dependencies Resolved
    [20131016.193536]   
    [20131016.193536]   ================================================================================
    [20131016.193536]    Package           Arch        Version                       Repository    Size
    [20131016.193536]   ================================================================================
    [20131016.193536]   Installing:
    [20131016.193536]    bind-utils        x86_64      30:9.3.6-20.P1.el5_8.6        updates      180 k
    [20131016.193536]    binutils          x86_64      2.17.50.0.6-20.el5_8.3        base         2.9 M
    [20131016.193536]    initscripts       x86_64      8.45.42-2.el5.centos.1        updates      1.6 M
    [20131016.193536]    shadow-utils      x86_64      2:4.0.17-21.el5               base         1.1 M
    [20131016.193536]   
    [20131016.193536]   Transaction Summary
    [20131016.193536]   ================================================================================
    [20131016.193536]   Install       4 Package(s)
    [20131016.193536]   Upgrade       0 Package(s)
    [20131016.193536]   
    [20131016.193536]   Total download size: 5.8 M
    [20131016.193536]   Downloading Packages:
    [20131016.193538]   --------------------------------------------------------------------------------
    [20131016.193538]   Total                                           2.6 MB/s | 5.8 MB     00:02     
    [20131016.193538]   Running rpm_check_debug
    [20131016.193538]   Running Transaction Test
    [20131016.193538]   Finished Transaction Test
    [20131016.193538]   Transaction Test Succeeded
    [20131016.193538]   Running Transaction
    [20131016.193538]   
    [20131016.193538]   Installing     : shadow-utils                                             1/4Error unpacking rpm package 2:shadow-utils-4.0.17-21.el5.x86_64
    [20131016.193538]    
    [20131016.193538]   warning: /etc/login.defs created as /etc/login.defs.rpmnew
    [20131016.193538]   error: unpacking of archive failed on file /usr/sbin/grpck: cpio: rename
    [20131016.193538]   
    [20131016.193538]   Installing     : bind-utils                                               2/4Error unpacking rpm package 30:bind-utils-9.3.6-20.P1.el5_8.6.x86_64
    [20131016.193538]    
    [20131016.193538]   error: unpacking of archive failed on file /usr/bin/host: cpio: rename
    [20131016.193538]   
    [20131016.193538]   Installing     : binutils                                                 3/4Error unpacking rpm package binutils-2.17.50.0.6-20.el5_8.3.x86_64
    [20131016.193538]    
    [20131016.193538]   error: unpacking of archive failed on file /usr/bin/ar: cpio: rename
    [20131016.193538]   
    [20131016.193538]   Installing     : initscripts                                              4/4Error unpacking rpm package initscripts-8.45.42-2.el5.centos.1.x86_64
    [20131016.193538]    
    [20131016.193538]   warning: /etc/adjtime created as /etc/adjtime.rpmnew
    [20131016.193538]   warning: /etc/rc.d/rc.local created as /etc/rc.d/rc.local.rpmnew
    [20131016.193538]   error: unpacking of archive failed on file /sbin/initlog: cpio: rename
    [20131016.193538]   
    [20131016.193538]   Failed:
    [20131016.193538]     bind-utils.x86_64 30:9.3.6-20.P1.el5_8.6                                      
    [20131016.193538]     binutils.x86_64 0:2.17.50.0.6-20.el5_8.3                                      
    [20131016.193538]     initscripts.x86_64 0:8.45.42-2.el5.centos.1                                   
    [20131016.193538]     shadow-utils.x86_64 2:4.0.17-21.el5                                           
    [20131016.193538]   
    [20131016.193538]   Complete!
    [20131016.193539]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
    [20131016.193549] E Sysup: Needed system RPMs were not installed: bind-utils, binutils, initscripts, shadow-utils
    [20131016.193549] ***** FATAL: Cannot proceed. Needed system RPMs were not installed.
    [20131016.193549]   The Administrator will be notified to review this output when this script completes
    [20131016.193549] E Detected events which require user notification during updatenow. Will send iContact the log
    => Log closed Wed Oct 16 19:35:49 2013
    [20131016.193549] E Running `/usr/local/cpanel/scripts/updatenow --upcp --log=/var/cpanel/updatelogs/update.1381948531.log` failed, exited with code 4608
    => Log closed Wed Oct 16 19:35:49 2013
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The cPanel update is failing because the required RPMS can not be installed. Here are the error messages of importance:

    Code:
    error: unpacking of archive failed on file /usr/sbin/grpck: cpio: rename
    error: unpacking of archive failed on file /usr/bin/host: cpio: rename
    error: unpacking of archive failed on file /usr/bin/ar: cpio: rename
    error: unpacking of archive failed on file /sbin/initlog: cpio: rename
    It's likely these files have the immutable attribute. You can verify this for each file with a command such as:

    Code:
    lsattr /usr/bin/host
    If you see the immutable flag, you will need to use "chattr" to remove the attribute, so the file can be updated successfully. If you did not set the immutable flag, check with your system administrator to see if there were any specific reasons it was configured in such a way.

    Thank you.
     
  3. Phil_b

    Phil_b Registered

    Joined:
    Aug 4, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    thanks.

    The above (for the relevant directories of my packages) solved the issue.
     
Loading...

Share This Page