The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel Upgrade Killed Exim,Help!

Discussion in 'General Discussion' started by jdhf99, Oct 16, 2004.

  1. jdhf99

    jdhf99 Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    I upgraded Cpanel and now in my service status it shows "exim (packageeximisnotinstalled)" it shows it as being up but I can't send or receive mail on any account. Anyone have any idea how to fix this?

    Thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Try:

    /scripts/exim4
     
  3. jdhf99

    jdhf99 Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Tried it, still shows up as exim "(packageeximisnotinstalled)" When trying to send mail to it from another account I get
    " Recipient: <support@clockworkcomputers.com>
    Reason: Verification failed for <jdhf@verizon.net> unrouteable mail domain "verizon.net" Sender verify failed"

    I've also tried to 'update' every version of cpanel in the list, these are other commands I've tried too...
    /scripts/reseteximtodefaults
    /scripts/mailperm
    /scripts/exim4 --latest
    chattr -i /etc/exim.conf
    /scripts/buildeximconf

    When trying the fresh install of Exim I see these errors in it.

    rpmdb: Lock table is out of available locker entries
    error: cannot open Packages index using db3 - Cannot allocate memory (12)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: Lock table is out of available locker entries
    error: cannot open Packages database in /var/lib/rpm

    Any help is appreciated, thanks again.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Once you've cleared up the locking issue with the above, have another go at /scripts/exim4 (note that the easiest way to clear those locks is a simple reboot).
     
  6. jdhf99

    jdhf99 Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Thanks;

    Okay, I restarted -- Now when I try to run /scripts/exim4 it freezes at
    "This is the exim 4.43 installer release number 0 for platform redhat AS-3"

    Postgresql is failing and when I try to restart it says 'postgresql has failed, please contact the sysadmin (result was "postmaster is not running").'

    Also, how do I forcefully kill a PID? up2date started itself twice and is taking almost 100% CPU usage and I can't kill it! :)

    In Service Status it now says
    "exim (exim-4.34-60_cpanel_stmpcontrol_antivirus_rewrite_mailman2_mailtrap_exiscan)"
    Instead of the package not being installed, so I think that is good? -- E-mail still bounces right away thougn.

    Thanks again.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can kill a process with:

    kill PID

    Where PID is the process ID. If that doesn't work, use:

    kill -9 PID

    If you're having up2date problems, that would explain the exim4 installation hanging.

    You could try running:

    up2date -l

    See whether that has any problems for you.
     
  8. ntwaddel

    ntwaddel Well-Known Member

    Joined:
    Nov 3, 2003
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Templeton, CA
    it killed mine too :confused:
     
  9. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    The last setup of updates didn't kill Exim all together on our servers, but I noticed that all of our boxtrapper accounts were disabled and all white/blacklist information was gone.
     
Loading...

Share This Page