The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel upgraded to v11 last night, but I've got two perl modules refusing to install

Discussion in 'General Discussion' started by schwim, Jun 6, 2007.

  1. schwim

    schwim Well-Known Member

    Joined:
    Aug 2, 2006
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Hi there,

    I woke up this morning to find that my cPanel install upgraded to v11. I also had two emails waiting for me. Can someone tell me what I need to do to install these two modules?

     
  2. schwim

    schwim Well-Known Member

    Joined:
    Aug 2, 2006
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    thanks,
    json
     
  3. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    What is the version of libxml2 that you have running and what is the linux Distro or Freebsd version?
     
  4. Big Gorilla

    Big Gorilla Active Member

    Joined:
    Jan 30, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Yea, I have the same problem on a CentOS 3.8 system that I haven't had a chance to fully investigate yet.

    For the record, this is the libxml2 I have on my system:

    Code:
    Name        : libxml2                      Relocations: /usr 
    Version     : 2.5.10                            Vendor: CentOS
    Release     : 7                             Build Date: Fri 12 Nov 2004 01:22:32 PM CST
    Install Date: Tue 10 May 2005 11:24:54 AM CDT      Build Host: centos-build
    Group       : Development/Libraries         Source RPM: libxml2-2.5.10-7.src.rpm
    Size        : 1738730                          License: MIT
    Signature   : DSA/SHA1, Fri 12 Nov 2004 01:27:27 PM CST, Key ID 7049e44d025e513b
    URL         : http://xmlsoft.org/
    Summary     : Library providing XML and HTML support.
    Perl, also, is version 5.8.8 installed using the cpanel perl installer.
     
    #4 Big Gorilla, Jun 6, 2007
    Last edited: Jun 6, 2007
  5. Big Gorilla

    Big Gorilla Active Member

    Joined:
    Jan 30, 2004
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    I ran checkperlmodules by hand and it shows they are installed properly.

    Code:
    XML::LibXML is up to date (1.63).
    Net::DAV::Server is up to date (1.29).
    /shrug

    I haven't found anything that doesn't work anyway.
     
  6. onepursuit

    onepursuit Member

    Joined:
    Jan 26, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I also found that my server had updated, found the same emails, and am now having a couple of issues:

    1. Fantastico reports that it installs scripts, but they do not function (DB errors)
    2. CPDAVD is running up my load averages

    How do I downgrade??? And how can I prevent my servers from auto-upgrading in the future?
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Regarding Fantastico, might want to contact their technical support staff regarding those issues.

    As for CPDAVD eating up your CPU, you may want to submit a support ticket to have someone look into fixing that for you.

    Downgrading is not recommended.

    However, if you are insistent - you can switch your server to STABLE and downgrade that way, however ensure to run /scripts/upcp --force after you downgrade just to ensure everything still functions as it should.

    Simply disable automatic upgrades in WHM -> Server Configuration -> Upgrade Config.
     
  8. onepursuit

    onepursuit Member

    Joined:
    Jan 26, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the quick response. I just went back to 10... Not really sure how that server wound up getting upgraded in the first place. Everything works fine again...
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Those are all related to cpdavd :)

    So if its sucking up cpu for you (or others in the thread), then that is probably the cause.
     
  10. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  11. onepursuit

    onepursuit Member

    Joined:
    Jan 26, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    The only complaint about those missing modules was in the email (at the time of the upgrade I presume). All other checks showed them to be installed properly... but something definitely wasn't working right. Going back to 10 made all the problems go away for me. (and yeah, I know that isn't really helpful or recommended or optimal...)
     
  12. schwim

    schwim Well-Known Member

    Joined:
    Aug 2, 2006
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Hi there guys,

    To respond to the original question concerning my problem, I'm running Fedora 4.

    Due to the number of responses from people with the same problem, some of the resolutions were ambiguous to who they were pointed to.

    Was it suggested to me to open a trouble ticket regarding this problem?

    thanks,
    json
     
  13. Jeffro

    Jeffro Member

    Joined:
    Jun 21, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Add one more user that has this problem. I downgraded to 10 and set up for no upgrades. I had a friend tell me when this happened that 11 has been known to have issues...
     
  14. jenlepp

    jenlepp Well-Known Member

    Joined:
    Jul 4, 2005
    Messages:
    116
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Liberty Hill, TX
    cPanel Access Level:
    DataCenter Provider
    Same here. I have 4 servers, two don't have the problem, two do, both the identical modules.
     
Loading...

Share This Page