Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cPanel URL always redirects to hostname

Discussion in 'Bind/DNS/Nameserver' started by web-hosting, Jan 17, 2018.

  1. web-hosting

    web-hosting Member

    Joined:
    Jan 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Office
    cPanel Access Level:
    Reseller Owner
    in address bar i open 1.2.3.4:2082 , its always redirect to hostname server1.domain.com:2083

    how to make it still using ip, not redirect to hostname?




    already trying changing values at whm - Tweak Settings - Redirect

    then try open 1.2.3.4:2082 or 1.2.3.4:2083 again
    but got this error:
    Your connection is not private

    so how to make the ip have ssl too? or still 1.2.3.4:2082 not redirect to 1.2.3.4:2083?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,852
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You'd need to disable the following option under the "Security" tab in "WHM >> Tweak Settings":

    Require SSL for cPanel Services

    Per it's description:

    This option forces the server to redirect unencrypted cPanel, Webmail, WHM, and DAV requests to secure ports according to the SSL redirection settings. If “Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs” is enabled, the system will redirect to the best matched certificate for the domain. If “Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs” is disabled, the system will redirect to the https:// URL for the domain, even if no valid certificate exists for the domain.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. web-hosting

    web-hosting Member

    Joined:
    Jan 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Office
    cPanel Access Level:
    Reseller Owner
    thank you, thats did it

    1.2.3.4:2082 already not redirect to hostname server1.domain.com:2083 again




    there is another problem, if i open 1.2.3.4:2083
    got this error:
    Your connection is not private

    how to make this url/ip have ssl?
    i have seen this in some webhosting, but still cant figure it by my self yet
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,344
    Likes Received:
    1,852
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You'd need to access cPanel over port 2083 using a domain name or hostname with a SSL certificate (e.g. hostname:2083, domain.tld:2083). Using the IP address and port 2083 directly in your browser will lead to SSL warnings because the certificate name is not matched to the browser address.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice