The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel users not getting addon domain email or able to control the add on domains

Discussion in 'E-mail Discussions' started by luvz2drv, Nov 10, 2008.

  1. luvz2drv

    luvz2drv Member

    Joined:
    Aug 5, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Okay cpanel 11.24 build from last night

    User had primary domain and like 4 addons .. all where working for all services

    now any email sent to the addon comes back as un routeable

    if you do a troubleshoot email -- it says deviever to local virtual email

    - goto clients cpanel -- Email -> in the drop down only has there primary domain

    nothing for any of there add on ones. also if you try to remove the addon domain from the addon page it says error domain is not under there control.

    but it is... any thoughts on this?

    edit of mroe info -- this is happening for all account not just this one.... no listing of the secondary (add on domains for email)

    Jonathon
     
    #1 luvz2drv, Nov 10, 2008
    Last edited: Nov 10, 2008
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The email address you are attempting to email, is it set up as example@addonDomain.com or example@primaryDomain.com?

    I ask because in a cPanel environment, all domains are treated as independent regarding email unless you explicitly set up an email domain forwarder.
     
  3. luvz2drv

    luvz2drv Member

    Joined:
    Aug 5, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    it was being sent to name@addondomain.com

    further troubleshooting has also found that the link between the primary domain or account and the addon has been lost as if you try to remove it or view it in the add on section it says it does not belong to that user.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This will be fixed in tonight's upcp. If you want to resolve it now:

    Code:
    /scripts/autorepair repair_xdns_entries
    
     
  5. S-Combs

    S-Combs Well-Known Member

    Joined:
    Jun 10, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Thank you kenneth. This fix was needed by us as well for the same exact problem.
     
  6. luvz2drv

    luvz2drv Member

    Joined:
    Aug 5, 2007
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    sure bet the heack out of my solution of rebuilding my clients account..

    lol
     
  7. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    In addition, we have tracked down at least one scenario that was causing this in 11.24.x. This scenario is resolved in 11.24 builds 30944 and 30943. If you don't have that build of 11.24 or higher installed, you will need to run the autofixer each day.
     
Loading...

Share This Page