Cpanel webmail not delivering email to a specific domain , but delivers through client

isacca

Registered
May 4, 2020
4
0
1
Jordan
cPanel Access Level
Reseller Owner
HI Everybody

I am new to here ....tried to search in forums but couldn't find a similar problem
I have WHM with my host , i migrated a new account to cpanel , changed the A record and MX record with the domain registrar ,
Email is sending and receiving fine except to one domain , email sent by cpanel webmail from my domain is not received on the other end on this specific domain and it happened with 19 mailboxes on this specific domain , all claimed not receiving email not in inbox nor in junk folder. The weird thing is that this only happens when using cpanel webmail , but when sending to this specific domain from Outlook mobile (i.e a client) mail gets delivered immediately.
i am not getting NDR's on webmail and not getting a delivery or read receipt as well . I know that email either delivers or bounces back , but getting lost like this is a strange thing.
Contacted my hosting company and they say that delivery report says it has been delivered

Any idea what is the problem here?

Thanks for the help
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
When you send mail using cPanel webmail what is output in the logs for mail being delivered to that domain? Since your profile notes you're a reseller you'd want to check in Track Delivery for the results.
 

isacca

Registered
May 4, 2020
4
0
1
Jordan
cPanel Access Level
Reseller Owner
It does not come back with anything on the track delivery ( no results not negative nor positive) and hosting company confirms it has been delivered , on the other hand they still did not get back to me on this specific issue after opening a support ticket.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
This is a bit confusing. Is the mail client set to send/receive from the domain where it is hosted now? Meaning have you updated the settings? There shouldn't be any reason you can't send mail using the webmail client if everything is set up as it should be. Your hosting provider should be able to tell you if they identify any issues with DNS.
 

isacca

Registered
May 4, 2020
4
0
1
Jordan
cPanel Access Level
Reseller Owner
This is a bit confusing. Is the mail client set to send/receive from the domain where it is hosted now? Meaning have you updated the settings? There shouldn't be any reason you can't send mail using the webmail client if everything is set up as it should be. Your hosting provider should be able to tell you if they identify any issues with DNS.
yes i updated all , it is sending through clients and through webmail and all is fine , it is only with one specific domain name , when i send to it using webmail they dont recieve my mail but when i send to them through a client they receive it
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
You need to contact your hosting provider for further assistance with this issue. There's nothing we can do as it sounds like some sort of misconfiguration.
 
  • Like
Reactions: isacca

keat63

Well-Known Member
Nov 20, 2014
1,913
259
113
cPanel Access Level
Root Administrator
May not be related, but worth me asking.
As you migrated an account, are you sure that you are connected to the new account and not somehow still connecting to the old server.
Did you remove the account from the old server. ?

What about cached web pages etc.
 
  • Like
Reactions: cPanelLauren

isacca

Registered
May 4, 2020
4
0
1
Jordan
cPanel Access Level
Reseller Owner
May not be related, but worth me asking.
As you migrated an account, are you sure that you are connected to the new account and not somehow still connecting to the old server.
Did you remove the account from the old server. ?

What about cached web pages etc.
I thought of this before , but i am connected to the new server , i double checked