Cpanel webmail not working after IP server change

keat63

Well-Known Member
Nov 20, 2014
1,913
259
113
cPanel Access Level
Root Administrator
How long since did you change the IP.
DNS may take a while to propogate.

Try to ping the url, see what IP it comnes back with.
Check that the DNS record doesn't have the old IP address listed against it.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Another thing to take into account is whether or not Service Subdomains are enabled for that domain.

You can run the following to enable/add them:

Code:
/scripts/servicedomains --user=$user add
 

salsidua

Registered
Nov 24, 2020
1
0
1
Spain
cPanel Access Level
Root Administrator
Hello, I have the same issue. The hosting provider change our IP address on one of our servers and the webmail redirection stop working, it always send us to the hostname website directory, and as the colleague mentions the https://mail.domain.xxx:2096 IP is working fine.... I try the options you propose and none of them works for me....
 

adam_dennis

Registered
Dec 6, 2020
1
0
0
Sydney
cPanel Access Level
Root Administrator
I am having exactly the same problem after a server migration. It is not a DNS issue as we moved the old server IP to the new server and all host names resolve correctly.
But the redirection to domainname:2087 is not working.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
5,447
697
313
cPanel Access Level
Root Administrator
@adam_dennis - sorry to hear about those issues! Webmail uses port 2096 so I wouldn't expect a hostname to get redirected to port 2087 on the system as that is the WHM login. webmail.domain.com or domain.com/webmail should redirect you to the proper area of the system.

Can you let me know specifically what happens when you say it's not working? Do you get an error in the browser or a time out? You may also want to make sure all the necessary ports are open for traffic on the new system after the migration, and we have a list of those here: