Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

/cpanel /webmail /whm slow, email auth broken

Discussion in 'E-mail Discussion' started by stratagem, Aug 27, 2008.

  1. stratagem

    stratagem Member

    Joined:
    Jul 10, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
    WHM v11.23.2, cPanel v11.23.6-R26866
    Automatic updates, release
    Intel Core2 Duo E4200, 2 GB RAM
    CentOS v5.2
    Apache v2.2.9
    40 (now 20) accounts
    Server load between 0.00 and 0.45
    OS, cPanel installed 1+ months ago
    Accounts transfered from cPanel 10.8 FC4 server

    This problem has developed within the last week, probably the last 2-3 days. Accounts on the server are not modified often once the user is happy with their setup and few if any ever have a bad word to say. So, until I heard about the problems with our nonexistent "upgrades" this morning in passing...I'll see if I can narrow down the time frame.

    • Web serving, scripts, and ftp are not affected.
    • Email logins are broken for pop3, imap, and webmail. The accounts exist but password authentication fails.
      "Aug 27 14:59:53 servername LOGIN FAILED, user=account@domain.tld, ip=[::ffff:1.2.3.4]
      Aug 27 14:59:53 servername pop3d: authentication error: Input/output error"
    • /cpanel, /webmail, and /whm redirects take between 90 and 180 seconds.
    • Accessing fqdn.servername.tld:2082, 2083, 2086, 2087, 2095, and 2096 results in a speedy login page (forced cookies).
    • Failed logins produce a message/login page in an acceptable time.
    • Control panel logouts are quick but the logout message portion of the logout confirmed page takes between 90-120 seconds to appear.
    • WHM page loads are somewhat jerky (pauses) but usable.
    • Control panel page loads take between 90 and 180 seconds.
    • Webmail page loads take between 90 and 180 seconds (until you're told that your supplied, correct password is wrong).
    • Accessing the server IP:port has no effect.
    • Page compression has no effect.
    • SSL, native or stunnel, has no effect.
    • Forced redirects to SSL has no effect.
    • Apache did not have the proxy module installed, rebuilt with easyapache successfully, including proxy. No effect.
    • Occurs on multiple ISPs, multiple routes - haven't found one that does not exhibit the issue.
    • I can't find any related messages in /usr/local/cpanel/logs or /var/log. Best I can do is:
      "Internal Error: "" Could not build an ssl connection: : Please speak ssl on this port"
    This occurs on all accounts. Suggestions? Help?
     
  2. stratagem

    stratagem Member

    Joined:
    Jul 10, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
  3. stratagem

    stratagem Member

    Joined:
    Jul 10, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
    Disabling cphulkd has corrected most of the WHM pauses and improved some control panel page load times.
    • /cpanel /webmail /whm redirects still take forever and a day.
    • WHM 'Edit DNS Zone' (for example) now starts to display quickly but still pauses a while before showing the listbox and zones.
    • Part of the control panel index displays quickly after login but still takes well over 60 seconds for dynamic content to appear.
    • Many sub-pages, like subdomains etc., now display quickly. Some still do not.
    Is Perl the source of my headache?
    http://forums.cpanel.net/showthread.php?t=90925
    Code:
    > /usr/local/bin/perl -v
    This is perl, v5.8.8 built for i386-linux-thread-multi
    
    > /usr/local/bin/perl -V
    Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
      Platform:
        osname=linux, osvers=2.6.18-53.1.14.el5pae, archname=i386-linux-thread-multi
        uname='linux builder16.centos.org 2.6.18-53.1.14.el5pae #1 smp wed mar 5 12:07:47 est 2008 i686 athlon i386 gnulinux '
    
    Built under linux
    Compiled at Jun 22 2008 21:07:12
    
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,480
    Likes Received:
    29
    Trophy Points:
    158
    cPanel Access Level:
    DataCenter Provider
    Does RELEASE_26881 solve this problem for you?
     
  5. stratagem

    stratagem Member

    Joined:
    Jul 10, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    151
    WHM 11.23.2 cPanel 11.23.6-R26881 (Release)

    Remaining issues are fixed. Re-enabled cPHulk, issues have not reappeared.

    Thank you Nick. I'll be reading the changelog :).
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice