cPanel & WHM 64.0 (build 13) - Java installed by itself?

MaRiOsGR66

Well-Known Member
Feb 18, 2011
111
1
68
cPanel Access Level
Root Administrator
Hello,

my cpanel server did the latest update automatically, and how it has the cPanel & WHM 64.0 (build 13) version.
When I check => Home »System Health »Process Manager

the first proccess I always see is by user cpanelsolr and the command is:
Code:
/usr/lib/jvm/jre-1.8.0/bin/java -server -Xms512m -Xmx512m -XX:NewRatio=3 -XX:SurvivorRatio=4 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=8 -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:ConcGCThreads=4 -XX:ParallelGCThreads=4 -XX:+CMSScavengeBeforeRemark -XX:PretenureSizeThreshold=64m -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=50 -XX:CMSMaxAbortablePrecleanTime=6000 -XX:+CMSParallelRemarkEnabled -XX:+ParallelRefProcEnabled -XX:-OmitStackTraceInFastThrow -verbose:gc -XX:+PrintHeapAtGC -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintTenuringDistribution -XX:+PrintGCApplicationStoppedTime -Xloggc:/home/cpanelsolr/server/logs/solr_gc.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=9 -XX:GCLogFileSize=20M -Dsolr.log.dir=/home/cpanelsolr/server/logs -Djetty.port=8984 -DSTOP.PORT=7984 -DSTOP.KEY=solrrocks -Dhost=127.0.0.1 -Duser.timezone=UTC -Djetty.home=/home/cpanelsolr/server -Dsolr.solr.home=/home/cpanelsolr/server/solr -Dsolr.install.dir=/home/cpanelsolr -Xss256k -Dsolr.autoSoftCommit.maxTime=3000 -Dsolr.log.muteconsole -XX:OnOutOfMemoryError=/home/cpanelsolr/bin/oom_solr.sh 8984 /home/cpanelsolr/server/logs -jar start.jar --module=http
did cpanel installed java/tomcat by it self?
 
Last edited by a moderator:

Rosal

Registered
Apr 19, 2017
1
0
1
Portugal
cPanel Access Level
Website Owner
I Have the same problem, after install the autoupdate cPanel & WHM 64.0 (build 13).

This process is consuming high memory.
When I check => Home »System Health »Process Manager

/usr/lib/jvm/jre-1.8.0/bin/java -server -Xms512m -Xmx512m -XX:NewRatio=3 -XX:SurvivorRatio=4 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=8 -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:ConcGCThreads=4 -XX:ParallelGCThreads=4 -XX:+CMSScavengeBeforeRemark -XX:PretenureSizeThreshold=64m -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=50 -XX:CMSMaxAbortablePrecleanTime=6000 -XX:+CMSParallelRemarkEnabled -XX:+ParallelRefProcEnabled -XX:-OmitStackTraceInFastThrow -verbose:gc -XX:+PrintHeapAtGC -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintTenuringDistribution -XX:+PrintGCApplicationStoppedTime -Xloggc:/home/cpanelsolr/server/logs/solr_gc.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=9 -XX:GCLogFileSize=20M -Dsolr.log.dir=/home/cpanelsolr/server/logs -Djetty.port=8984 -DSTOP.PORT=7984 -DSTOP.KEY=solrrocks -Dhost=127.0.0.1 -Duser.timezone=UTC -Djetty.home=/home/cpanelsolr/server -Dsolr.solr.home=/home/cpanelsolr/server/solr -Dsolr.install.dir=/home/cpanelsolr -Xss256k -Dsolr.autoSoftCommit.maxTime=3000 -Dsolr.log.muteconsole -XX:OnOutOfMemoryError=/home/cpanelsolr/bin/oom_solr.sh 8984 /home/cpanelsolr/server/logs -jar start.jar --module=http
This is normal?
 

vacancy

Well-Known Member
Sep 20, 2012
409
127
93
Turkey
cPanel Access Level
Root Administrator
Yes, it is normal.

This is part of the cpanelsolr process.

Speeds up mail (dovecot) directory/services search-listing.

If you do not have high mail traffic, you can disable it via the service manager.
 
Last edited:
  • Like
Reactions: Rosal

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Really wish this hadn't been auto enabled, as it really only seems to be necessary on a small percentage of servers that run large IMAP inboxes.
The IMAP Full-Text Search Indexing (powered by Solr) plugin is disabled by default. You have to manually enable it via "WHM >> Manage Plugins", or choose to enable it via the Feature Showcase interface when accessing Web Host Manager after the update to cPanel 64.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Thanks, I see you are correct. The "Spotlight" defaults to "enable" so when clients just click to save it is being enabled when they don't need it at all.
Hello,

I'm seeing the default value of "No Thanks" after updating a test system to cPanel 64:

solr.png

Are you noticing different behavior?

Thank you.
 

Archmactrix

Well-Known Member
Jan 20, 2012
138
2
68
cPanel Access Level
Root Administrator
Thanks, I see you are correct. The "Spotlight" defaults to "enable" so when clients just click to save it is being enabled when they don't need it at all.
This was probably the case when I viewed the "Feature Showcase interface" but forgot about it, or perhaps it was disabled before I chose to enable it. It reminds me to be more careful when introduced to new features like IMAP Full-Text Search Indexing that may utilize proportionally far more server resources compared to what can be gained from it in my own user case.

I'm not running email hosting for others and have really no use for this for my own emails, so I was surprised to see that the cpanelsolr process had more memory use than the mysql process on my server. But this is a special case as my server is underutilized and this was not impacting the server performance.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
I just found a server that still prompted the "Spotlight", and "enable" was the preselected default.
Hello,

Could you open a support ticket using the link in my signature so we can take a look at this system and see why it's enabled by default?

Thank you.