Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cPanel & WHM 70 - Known Issues

Discussion in 'General Discussion' started by cPanelMichael, May 9, 2018.

Tags:
Thread Status:
Not open for further replies.
  1. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,197
    Likes Received:
    1,936
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello Everyone!

    Here's an overview of some of the reported issues specific to cPanel & WHM version 70:

    Case Number: CPANEL-20644
    Status: In-Progress
    Description: Backups can fail on higher latency disks (e.g. NAS, NFS) with an error message like this:

    Code:
    The system received an error from the “SQLite” database “/nas/backup/.meta/dbame.db”: SQLITE_ERROR (no such table: backup_paths) at /usr/local/cpanel/Cpanel/Exception/CORE.pm line 336.
    Workaround: Disable the use of metadata files by running the following command as "root":

    Code:
    whmapi1 backup_config_set disable_metadata=yes
    Note when metadata creation is disabled , the following actions occur:
    • WHM disables the File and Directory Restoration interface (Home >> WHM >> Backup >> File and Directory Restoration). The interface will display a warning that indicates the setting that disabled it.
    • cPanel hides the File and Directory Restoration interface (Home >> cPanel >> Files >> File and Directory Restoration) from the cPanel Home interface.
    Forums Thread: Backup failure - SQLITE_ERROR (no such table: backup_paths)
    Case Number: CPANEL-20545
    Status: Fix scheduled for cPanel & WHM version 74.
    Description: The /etc/mailhelo file is incorrectly populated with a reseller's domain name in cases where account's are assigned a dedicated IP address and owned by a reseller. This happens with the following option is enabled in WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor:

    Send mail from account's dedicated IP address

    Workaround: Temporarily disable the following option in WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor:

    Send mail from account’s dedicated IP address

    Then, if you want to modify which IP address Exim uses for sending emails until a solution is published, you'd need to follow the instructions documented on the following link:

    Manually configure Exim's outgoing IP addresses

    Forums Thread: In Progress - [CPANEL-20545] Exim sending email (-53) retry time not reached for any host
    Case Number: CPANEL-20566
    Status: Solved in version 70.0.46.
    Description: Using the "Unencrypted" option in WHM >> Transfer Tool fails to connect or transfer accounts with 301 moved errors.
    Workaround: Transfer accounts using the encrypted option.
    Forums Thread:N/A
    Case Number: CPANEL-20560
    Status: Solved in version 70.0.46.
    Description: The following error messages appear during the cPanel update, preventing the update from completing:

    Code:
    E [/usr/local/cpanel/scripts/update_spamassassin_config] The “/usr/local/cpanel/scripts/update_spamassassin_config” command (process 2586) reported error number 255 when it ended.
    Code:
    warn [update_spamassassin_config] Failed to update neighbor netblocks because of an error:  at /usr/local/cpanel/3rdparty/perl/524/lib64/perl5/cpanel_lib/Net/Whois/IANA.pm line 538.
    Workaround: None at this time.
    Forums Thread: [CPANEL-20560] Update failure with /scripts/update_spamassassin_config
    Case Number: CPANEL-20331
    Status: Solved in version 70.0.46.
    Description: This case is open to address an issue where a "rejected by local scanning code" email delivery failure message occurs during the update to cPanel & WHM version 70 as part of the attempt to notify the root contact about the upcp cron job.
    Workaround: To be determined.
    Forums Thread:Mail failure - rejected by local scanning code
    Case Number: CPANEL-20499
    Status: Solved in version 70.0.44.
    Description: Using WHM >> Transfer Tool with the "Copy Home Directory" option deselected for an account prevents a successful transfer.
    Workaround: Manually transfer the accounts using the Pkgacct (with the --skiphomedir flag) and Restorepkg scripts.
    Forums Thread:Transfers fail when "Copy Home Directory" is deselected
    Case Number: CPANEL-20179
    Status: Solved in version 70.0.42
    Description: Websites associated with accounts assigned the PHP-FPM handler show 503 errors after account creation.
    Workaround: Manually restart PHP-FPM using the /scripts/restartsrv_apache-php-fpm command.
    Forums Thread: SOLVED PHP-FPM isn't restarted for new accounts
    Case Number: CPANEL-20319
    Status: Solved in version 70.0.34
    Description: This case is open to address an issue where updating to cPanel & WHM version 70 leads to the creation of duplicate "A" records for proxy subdomains in cases where the "A" record for a proxy subdomain was previously overwritten with a non-default value.
    Workaround: Manually removing the duplicate "A" records for the affected domain names using "WHM >> Edit DNS Zone" is currently the best approach.
    Forums Thread:CPANEL-20319 - Duplicate A Records For Proxy Subdomains
    Case Number: CPANEL-20286
    Status: Solved in version 70.0.34
    Description: This case is open to address an issue where cPanel >> File Restoration and WHM >> File Restoration don't function properly when a trailing slash is utilized in the path for Default Backup Directory in WHM >> Backup Configuration. Attempting to restore a file using the File Restoration feature in cPanel or WHM will result in a “file does not exist” error message appearing in the interface.
    Workaround: Browse to WHM >> Backup Configuration and remove the trailing slash from the path utilized for Default Backup Directory.
    Forums Thread:/$filename does not exist error in File Restoration
    CentOS Bug Report: Bug 1577265 – nospoof, spoof, and spoofalert were not implemented and apparently removed.
    Status: This relates to a RHEL/CentOS bug and is not caused by a change in cPanel & WHM.
    Description: CentOS/RHEL version 7.5 no longer supports the following commands in the /etc/host.conf file:

    nospoof
    spoofalert
    spoof


    This can lead to the following issues:

    1. Prevents /scripts/check_cpanel_rpms from running.
    2. Mailing lists no longer appear in cPanel.
    3. It's not possible to list Mailing List members using the command line.
    4. Web Host Manager reports "UNKNOWN" for the operating system version.

    Workaround: Remove or comment out the lines that contain the spoof, spoofalert, or nospoof commands from the /etc/hosts.conf file.
    Forums Thread: Cron jobs now failing with nospoof error

    We'll update this thread with new information as it becomes available. The full change log is available at:

    70 Change Log - Change Logs - cPanel Documentation

    You can ask questions or add comments about an issue by replying to it's corresponding forums thread. Additionally, please feel free to open a new thread to report an issue that's not listed on this thread, or to let us know of any general questions or feedback regarding cPanel & WHM version 70. We're here to help!

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...
Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice