The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel/whm Apache not installing

Discussion in 'EasyApache' started by h3lios, Dec 19, 2007.

  1. h3lios

    h3lios Member

    Joined:
    Nov 7, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I just installed cpanel/whm on Freebsd 6.2

    The whole installation went fine. I even finished the WHM setup with no issues.
    I did however notice that apache was not running on port 80. I tried looking for the apache binaries and couldn't find them.

    When I ran /scripts/easyapache I got the following error:


    /easyapache
    !! Pre allocation testing was successfully able to allocate 90MB !!
    !!
    Ouput from '/bin/sh -c "ulimit -a"':
    cpu time (seconds, -t) unlimited
    file size (512-blocks, -f) unlimited
    data seg size (kbytes, -d) 524288
    stack size (kbytes, -s) 65536
    core file size (512-blocks, -c) 1048576
    max memory size (kbytes, -m) 524288
    locked memory (kbytes, -l) unlimited
    max user processes (-u) 5547
    open files (-n) 11095
    virtual mem size (kbytes, -v) 524288
    sbsize (bytes, -b) unlimited
    !!
    Can't locate Curses/UI.pm in @INC (@INC contains: /scripts/../lib /usr/local/cpanel /var/cpanel/easy/apache/custom_opt_mods /var/cpanel/perl/easy /scripts /usr/local/lib/perl5/5.8.8/BSDPAN /usr/local/lib/perl5/site_perl/5.8.8/mach /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.8.8/mach /usr/local/lib/perl5/5.8.8 .) at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI/Config.pm line 5.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI/Config.pm line 5.
    Compilation failed in require at /var/cpanel/perl/easy/Cpanel/Easy/Apache/UI/CLI.pm line 298.





    Does anyone know why this happened, and more importantly, how I can fix this?


    Thank you.
     
  2. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Try running the following from the command line as root:

    Code:
    /scripts/realperlinstaller Curses::UI
    The Curses::UI perl module is missing form your system
     
Loading...

Share This Page