Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

cPanel/WHM & cPanel DNSONLY HTTP 401 - Invalid Security Token issue

Discussion in 'Bind/DNS/Nameserver' started by ComputerMaster1, Aug 31, 2014.

  1. ComputerMaster1

    ComputerMaster1 Registered

    Joined:
    Aug 31, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi there,

    I've recently purchased cPanel on Friday and installed it as normal and works. It also had a self-signed SSL installed aswell by default. I have purchased SSL from cloudflare and has now replaced the self signed certificates.
    (from red https to green https). Now that I have the green https, cPanel/WHM & cPanel DNSONLY are now triggering "Invalid Security Token". Here are some screenshots I have done to help you understand.

    Login >> - Removed - (Normal login takes me to this so it does know my account details)

    Logged in again >> - Removed - (After logging in again & 401 invalid security token appears)

    Same on another server I have, however no 401 appeared. However is present in the dev tools >> - Removed -

    Entered password for security token >> Does nothing, diverts back to 401 again.

    I use Chrome as my main browser and have cleared all cookies and cache. I have performed the same on Internet Explorer and I receive the same results... 401 remains. The 401 is random.

    This started happening ever since I've purchased SSL from cloudflare (green https). It worked fine with a self-signed SSL (red https).

    I am unsure what has happened and I am now seeking for your support to help have this issue resolved.

    I am using cPanel/WHM 11.44.1 & cPanel DNSONLY 11.44.1.

    Thank you. :)
     
    #1 ComputerMaster1, Aug 31, 2014
    Last edited by a moderator: Sep 2, 2014
  2. ComputerMaster1

    ComputerMaster1 Registered

    Joined:
    Aug 31, 2014
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi there,

    After doing some googling, I've eventually found the fix for it. Had to turn off "Cookie IP Validation" as cPanel/WHM I've installed was running on my server running behind cloudflare. When I connect to it through cloudflare, it changes my IP and that was the cause of the HTTP ERROR 401. All fixed now anyway. :)

    It is now safe to close this thread.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,385
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello :)

    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice