cPanel/WHM crash on new accounts. (run /scripts/updatenow;/usr/local/cpanel/startup)

buccaneerob

Active Member
Feb 3, 2003
27
0
151
Latest update causes Cpanel to crash after creating new account!?!?

It seems like ever since I've updated to the latest version that every time a new account is trying to be created CPanel crashes!

I'm unable to access WHM, e-mail, apache is still functioning however.

After restarting Cpanel, it all comes back up, until trying to create a new account again!

Any ideas would help!

Thanks
Rob

cPanel.net Support Ticket Number:
 

thedavid

Well-Known Member
Nov 22, 2002
124
0
166
Originally posted by bdraco
Do you have the EXPERIMENTAL web root protection turned on?

cPanel.net Support Ticket Number:
I actually just started getting this too. Most recent release, updated today. The server that this is on is a stock rackshack server I just ordered/setup today, so it's a plane-jane cpanel install. I also noticed that there were no accounts in the account list.

Interesting. Since I just got the server today and am not really using it for paying customers, not that big of a deal. But still strange.

I did re-compile apache, php, and the kernel but did not select the option for experimental web root protection.

-David

cPanel.net Support Ticket Number:
 

sexy_guy

Well-Known Member
Mar 19, 2003
847
0
166
Second time today that all Login functions fail!!!

Whats going on with this? We havent upgraded in ages yet today all our sites lost the ability to log into their control panels twice. Both times people were getting a PAGE NOT FOUND.

When i restarted it i saw this;

[email protected] [/home/admin]# /etc/rc.d/init.d/cpanel3 stop
Stopping Cpanel7 services: [FAILED]
Stopping Cpanel7 log services: [FAILED]
Stopping Cpanel7 Chat services: [FAILED]
Stopping Melange Chat services: [FAILED]
Stopping InterChange services: [ OK ]
Stopping Cpanel3 ssl services: [FAILED]
Stopping Web Host Manger services: [FAILED]
[email protected] [/home/admin]#

Whats up with this?

Then i started it. Give it another 8hrs and we will have to start this again. Whats up with this? We havent upgraded in 3 weeks now all of a sudden we are getting this?

cPanel.net Support Ticket Number:
 

Dathorn_ADT

Active Member
Nov 16, 2002
42
2
158
cPanel Access Level
Root Administrator
This has happened on several of our servers as well, all after the time of which they each would have updated this morning. Quite annoying to say the least.

cPanel.net Support Ticket Number:
 

andyf

Well-Known Member
Jan 7, 2002
249
0
316
UK
Getting this across a whole load of servers here too. bdraco?

cPanel.net Support Ticket Number:
 

royisher

Member
Feb 19, 2003
16
0
151
Also here

It went down also here, and the option for experimental web root protection is off.

cPanel.net Support Ticket Number:
 

andyf

Well-Known Member
Jan 7, 2002
249
0
316
UK
No idea, but this is causing us major problems. It needs sorting ASAP.

[edit]

Edge90 does NOT resolve the problem.
 
Last edited:

Dathorn_ADT

Active Member
Nov 16, 2002
42
2
158
cPanel Access Level
Root Administrator
This is absolutely ridiculous, what kind of piss poor testing do they even do on this before releasing it? The problem is indeed caused by creating new accounts.

cPanel.net Support Ticket Number:
 

Chelp2

Active Member
Mar 28, 2003
27
0
151
Same here.

What is going on. We don't auto update anymore to try to avoid things like this happening and now there are no cpanel functions.

That is so Irritating.

cPanel.net Support Ticket Number:
 

maxbia

Active Member
Feb 11, 2003
34
0
156
Are all you guys on release ? i hope this isnt on stable :)

cPanel.net Support Ticket Number:
 

LS_Drew

Well-Known Member
Feb 20, 2003
187
0
166
sorry for horning in on your problem here guys, but what is 'experimental web root protection' and how can we learn more about it, test it, etc?

cPanel.net Support Ticket Number:
 

hostultra

Well-Known Member
Aug 21, 2002
167
0
166
Well at least i know what happened now.
I thought my box was hacked :eek:

Im downgrading back to Cpanel-7.2.1-STABLE_85 hopefully that fixes it.

I dont know if this is related but my APF firewall was also down aswell as cpanel/whm/email

How come every time cpanel updates i get this email:
apache failed @ Thu Jul 24 07:59:18 2003. A restart was attempted automagicly.
 

casey

Well-Known Member
Jan 17, 2003
2,288
0
191
Originally posted by LS_Drew
sorry for horning in on your problem here guys, but what is 'experimental web root protection' and how can we learn more about it, test it, etc?

cPanel.net Support Ticket Number:
The web root protection is an option in the buildapache script. I am using it, and I have had no problems so far.

cPanel.net Support Ticket Number:
 

bjarne

Well-Known Member
Mar 23, 2002
135
0
316
I also have this!!!

I have one server wich craches on creating of new accounts, so the user is added, the httpd.conf is added and a empty file is put in /etc/profftpd and the domain is added to /etc/localdomains

exim_paniclog is complaining about mail being send to root wich is listed in config as never_user or something.

I just upgraded apache to 1.3.28 and also installed the clamp virus thing but did not! enable this webroot protection,

###

I also had empty system mail adresses in WHm and added some normal email adress becuase I think it might be connected to root's mail and exim flipping out.

cPanel.net Support Ticket Number:
 
Last edited:

jamesbond

Well-Known Member
Oct 9, 2002
737
1
168
Originally posted by casey
The web root protection is an option in the buildapache script. I am using it, and I have had no problems so far.
And what does it do exactly, does it work properly?

cPanel.net Support Ticket Number:
 

smit1

Member
Feb 21, 2003
18
0
151
We're another one with this, we contacted CP support yesterday and they said they are working on a fix for the near future, hope that's pretty darn near in the future lol - restarting cpanel gets the :2082 :2086 pop3 etc back up until someone adds another account if this helps anyone

Jamie

cPanel.net Support Ticket Number: