cPanel/WHM Doesnt Work Anymore!

IrPr

Member
Aug 29, 2006
5
0
151
Hi All,
I WAS running cPanel/WHM on my RHEL4 box
here is my Kernel Version: 2.6.9-34.ELsmp
as i noticed that kernel is vulnerable and WHM warned me, i planed to upgrading Kernel to 2.6.9-39.0.2.ELsmp
i upgraded my kernel without any problem and rebootet my server

Apache and MySQL are ok but cPanel doent work anymore!
i cant login to my cPanel through 2082-2087 Ports

here is my cPanel server status:
Code:
[email protected] [~]# service cpanel status
cpsrvd (pid 3565) is running...
entropychat (pid 3587) is running...
melange (pid 3591) is running...
stunnel is stopped
interchange is stopped
qrunner is stopped
[email protected] [~]#
Any suggestion ?

( Sorry for my f**kin Englis )
 

IrPr

Member
Aug 29, 2006
5
0
151
yes, a lot!
Code:
[email protected] [~]# service cpanel restart
Stopping cPanel services:                                  [  OK  ]
Stopping pop3 services:                                    [  OK  ]
Stopping cPanel log services:                              [  OK  ]
Stopping cPanel Chat services:                             [  OK  ]
Stopping Melange Chat services:                            [  OK  ]
Stopping InterChange services:                             [FAILED]
Stopping cPanel ssl services:                              [  OK  ]

Stopping mailman services: Shutting down Mailman's master qrunner

Starting eximstats:                                        [  OK  ]
Starting cPanel services:                                  [  OK  ]
Starting cPanel Log services:                              [  OK  ]
Starting pop3 services:                                    [  OK  ]
Starting cPanel Chat services:                             [  OK  ]
Starting Melange Chat services:                            [  OK  ]
Starting cPanel ssl services:                              [  OK  ]
Starting mailman services: Starting Mailman's master qrunner.

[email protected] [~]#
here is my listening TCP/UDP Ports:
Code:
[email protected] [~]# netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State
tcp        0      0 *:tcpmux                    *:*                         LISTEN
tcp        0      0 *:2082                      *:*                         LISTEN
tcp        0      0 *:2083                      *:*                         LISTEN
tcp        0      0 *:2084                      *:*                         LISTEN
tcp        0      0 *:2086                      *:*                         LISTEN
tcp        0      0 *:2087                      *:*                         LISTEN
tcp        0      0 *:6666                      *:*                         LISTEN
tcp        0      0 *:mysql                     *:*                         LISTEN
tcp        0      0 *:2095                      *:*                         LISTEN
tcp        0      0 *:sunrpc                    *:*                         LISTEN
tcp        0      0 localhost:783               *:*                         LISTEN
tcp        0      0 *:2096                      *:*                         LISTEN
tcp        0      0 *:http                      *:*                         LISTEN
also i can lynx to my cPanel trough localhost
 

oulzac

Well-Known Member
Aug 7, 2005
131
0
166
reboot the server.

then when the server comes backonline, edit your root cron and remove the /scripts/upcp line from it.
 

IrPr

Member
Aug 29, 2006
5
0
151
oulzac said:
reboot the server.

then when the server comes backonline, edit your root cron and remove the /scripts/upcp line from it.
done
but nothing happend
here is my cPanel service status:
Code:
[email protected] [~]# service cpanel status
cpsrvd (pid 3798 3797 3796) is running...
entropychat (pid 3819) is running...
melange (pid 3823) is running...
stunnel is stopped
interchange is stopped
qrunner is stopped
[email protected] [~]#
stunnel is still stopped
 

angelina_holy

Well-Known Member
Aug 6, 2006
113
0
166
Check the error logs in /usr/local/cpanel/logs/
then do tail -f error_logs

What does it say ?

Try to run the script ./cpsrvd in /usr/local/cpanel

There is another possibility , DO you have apf installed ? if yes check ,

cd /etc/apf
nano conf.apf
Configure the ports
# Common ingress (inbound) TCP ports
IG_TCP_CPORTS = 2082 , 2083 ...
 

rocketxau

Member
Oct 23, 2005
5
0
151
Something just happened with our server that is similar to this problem.

Our server was rebooted but now the SSL ports for Cpanel/WHM don't work anymore.

2083 and 2087 can be connected to, but they dont return any data.

I've tried restarting cPanel several times but it still doesnt work? Any clue on what it might be?

Code:
cpsrvd (pid 8318) is running...
entropychat (pid 8324) is running...
melange (pid 8328) is running...
stunnel is stopped
interchange is stopped
qrunner is stopped
Ports are also listening:

Code:
tcp        0      0 *:2082                      *:*                         LIS 
tcp        0      0 *:2083                      *:*                         LIS 
tcp        0      0 *:2084                      *:*                         LIS 
tcp        0      0 *:2086                      *:*                         LIS 
tcp        0      0 *:2087                      *:*                         LIS
Any help on the matter would be great.

Thanks
 

cImrie

Registered
Aug 5, 2006
1
0
151
Hampshire, UK
Do this;

cd /usr/local/cpanel/src/3rdparty/gpl/
tar xzf stunnel-4.15.tar.gz
cd stunnel-4.15
./configure
make

Then; (Ensure stunnel is stopped by doing this)

ps aux | grep stunnel
kill -9 PID (PID for stunnel if running at all, double check, as it could be lying)

Then;

cp -p src/stunnel /usr/bin/stunnel-4.15local

Then;

/scripts/rebuiltcpanelsslcrt

Then;

service cpanel restart