The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel/WHM messed with CentOS updates

Discussion in 'General Discussion' started by sehh, May 19, 2007.

  1. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    Today the cPanel update script exectued "yum update" which failed to update anything.

    I did a manual "yum update" to see what went wrong and found this:

    --> Running transaction check
    --> Processing Dependency: glibc-common = 2.3.4-2.25 for package: glibc-dummy-centos-4
    --> Finished Dependency Resolution
    Error: Missing Dependency: glibc-common = 2.3.4-2.25 is needed by package glibc-dummy-centos-4


    Apparently, glibc-dummy-centos-4 requires glibc-common which isn't found because glibc-dummy-centos-4 it has been replaced by cPanel's own version: glibc-dummy-centos-4-2.3.4-2.25.swsoft.

    Anyone having a similar problem?
     
  2. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I second this problem.
     
  3. sehh

    sehh Well-Known Member

    Joined:
    Feb 11, 2006
    Messages:
    579
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Europe
    problem solved:

    just "rpm -e glibc-dummy-centos-4" to remove the existing package (use --force or --nodeps if required)

    then just "yum update" and it will work.
     
Loading...

Share This Page