The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cpanel & WHM not saving passwords in Chrome

Discussion in 'General Discussion' started by planetjoin, May 17, 2012.

  1. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello

    Since 1 month ago, I´m having problems using Chrome with Cpanel and WHM.
    When i login, the browser never ask me if i want to save password. This only happens with Chrome (i can save password perfectly with FF and IE).

    I´ve already have set in Tweaks Settings this in OFF:

    Enable HTTP Authentication [?]
    Enable HTTP Authentication for cPanel/WebMail/WHM Logins. This risks certain types of XSRF attacks that rely on cached HTTP Auth credentials. Disabling forces cookie authentication.


    I`ve tried everything, clear cache, etc. but Chrome still not asking to save password. This ONLY happens with whm and cpanel (2086 and 2082) and NOT happens with other sites.

    I´m Using :
    WHM 11.32.2 (build 25)
    CENTOS 5.8 x86_64

    Chrome 19.0.1084.46

    Any tip??

    Regards
    Fabian
     
  2. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Well!!

    I ask and i answer :)

    I discover the problem. Maybe it happens to many of you and would be great if cpabel people can fix it.

    The problem is not Chrome. The problem is the "new" login display of Cpanel/WHM.

    I go to Tweak setttings --> Display and change "Default login theme" from : cpanel default (the new one, blue and nice design) to cpanel-legacy (The old login display screen).

    Now, Chrome ask me to save the username and password perfectly !

    and some good : if now go to tweak setting.. display.. etc. and change again to "cpanel default" the username and password is now stored and works perfectly :)

    Surely is a simple JS issue on the new login display screen.

    Regards
    Fabian
     
  3. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello

    Anyone in Cpanel could seee this bug of the new login display screen?

    Could be great if you can see this and fix the bug , then.. all we uses Chrome can use the new interface to login.

    Regards
    Fabian
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    WHM > Server Configuration > Tweak Settings, Security tab, find this item at top and turn it on:
    Allow autocomplete in login screens.
     
  5. LDHosting

    LDHosting Well-Known Member

    Joined:
    Jan 19, 2008
    Messages:
    93
    Likes Received:
    2
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    I think that there is a case open for this (perhaps you can confirm, infopro?). I was told case #58661 when I contacted cPanel regarding this same issue last month.

    cPanel tickets ID# 2508783
     
    #5 LDHosting, May 18, 2012
    Last edited: May 18, 2012
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thank you for that. That case has been closed and fix is on the way for Chrome as I understand it. Not released yet, but on the way.
     
  7. LDHosting

    LDHosting Well-Known Member

    Joined:
    Jan 19, 2008
    Messages:
    93
    Likes Received:
    2
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    No worries, Infopro. Thanks for double checking. :)

    Yeah, I think the tech mentioned 11.32.3 which, of course, hasn't been released yet (the case also didn't appear in the 11.32.3.15 changelog which is currently in Edge).

    If only it didn't take cPanel an age to correct bugs that they have introduced. This bug will have been there for around 2 months by the time they fix it (assuming 11.32.3 goes into release in the next few weeks.) :(
     
  8. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello

    Sorry but the problem still not fixed :(

    I´m using this :
    WHM 11.32.2 (build 25)
    CENTOS 5.8 i686

    I´ve tried everything
    I already turn in on this :

    WHM > Server Configuration > Tweak Settings, Security tab, find this item at top and turn it on:
    Allow autocomplete in login screens.

    But still happens the same in Chrome :

    if you use the "cpanel default" in ON under Tweak Setttings --> Display (new login theme) Chomre not ask to save password
    but if you change it in WHM to "cpanel-legacy" , then Chrome ask to save the password.

    ONce the password is saved, even changing to cpanel default the password is stored in the browser and works fine. BUT, LOT of hosters have "cpanel default" as default and then.. with Chrome we can´t save the passwords.

    Is any patch to install or something to do to fix this ?

    Regards
    Fabian
     
  9. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello again

    I´m seeing I´m using the "RELEASE" version : 11.32.2.25

    Maybe the fix for Chrome is in the "CURRENT" version ? : 11.32.3.17

    If yes, when 11.32.3.17 will be RELEASE ?

    Regards
    Fabian
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You can keep an eye out for this case number (58661) in the changelog if you wish:
    Change Logs

    I've just tested using Chrome on an EDGE server and its not saving my password. You may need to use some sort of password manager or another browser in the meantime until the fix for this propagates to your tier.
     
  11. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Just tested with WHM 11.32.3 (build 19) + Chrome 19.0.1084.52

    Password NOT being saved

    I also toggled "Allow autocomplete in login screens." just to be sure.

    Please fix guys :)
     
  12. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello

    i just tested it now with WHM 11.32.3 (build 19) and still not save the password :(
    I´m using Firefox since a month or so becasue this.. and i miss Chrome !!!

    Plase fix it guys !

    Fabian
     
  13. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've just tested this multiple times and can't get Chrome to save my password no matter what I do. I'll see if I can find out anything more on this.
     
  14. planetjoin

    planetjoin Active Member

    Joined:
    Oct 14, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello

    i just tested it now with WHM 11.32.3 (build 19) and still not save the password :(
    I´m using Firefox since a month or so becasue this.. and i miss Chrome !!!

    Plase fix it guys !

    Fabian
     
  15. vikins

    vikins Well-Known Member

    Joined:
    Oct 3, 2006
    Messages:
    93
    Likes Received:
    1
    Trophy Points:
    8
    Same thing here. Chrome 19.0.1084.52 and WHM 11.32.3 (build 19)
     
  16. Duhg

    Duhg Registered

    Joined:
    Jun 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am currently locked out of my site, however it was an upgrade that I had to authorize. Besides that, I have been using LastPass for my passwords and Chrome when it asks to save. I have noticed that https:// sites are not being asked for password by Chrome.
     
  17. WhiteDog

    WhiteDog Well-Known Member

    Joined:
    Feb 19, 2008
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    For the record: autocomplete is not working for me in ANY browser at the moment with cPanel 11.32.3.19.
    Is this related to another setting (e.g. Allow HTTP Authentication) to be able to "work".

    Also, as the login themes are editable, I assume we can troubleshoot / fix this ourselves ?
     
  18. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Here's an update on this for you. This issue with Chrome is not new, nor cPanel specific, it's actually an ongoing issue that cPanel has been attempting to work around for some time now. More on the issue here:
    Password not remembered when login form uses XHR or equivalent - code.google.com

    Suggested workaround by cPanel Developers:

    1) Disable JavaScript, login, then logout, then re-enable JavaScript. Subsequent logins will be auto-filled.
    2) Install a Chrome addon that extends Chrome’s ability to save passwords.
    3) Use a non-WebKit browser.

    I have tried item #1 and it works as expected. On first hitting the login page with javascript disabled, you're greeted with a warning, ignore that and type in your login details and login. Once you get in, Chrome then asks if you'd like to save your password, choose yes. Now logout. Enable Javscript again, try WHM login page. You'll see your username and password already filled in.

    Hope that helps.
     
  19. JohnD60

    JohnD60 Registered

    Joined:
    Jul 23, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Cobourg, Canada
    I have the same problem in Firefox, CPanel/WHM 11.32.2. It's 100% fixed if I use fix mentioned - that is, use tweak settings to go to legacy login-form. Thanks for the tip - a great time saver.
     
  20. Diniel

    Diniel Member

    Joined:
    Jan 31, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, Fabian!

    I use Chrome and have toggled off/on the autosave option too, with no luck. Changing the theme to the legacy theme and logging in again does indeed allow Chrome to ask if I'd like to save the password, and then switching the theme back to cPanel does indeed work - current theme and saved password.
     
Loading...

Share This Page