The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cpanel/whm on a mobile/smartphone

Discussion in 'General Discussion' started by oulzac, Dec 7, 2009.

  1. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Why can I never login to WHM or cpanel from a winmo phone?
    It always says login failed, even though I can login with just fine on any computer.

    Is there a setting that can be changed to allow this, or is there a plan to make a mobile plugin for us mobile users?
     
  2. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please try the following method as referenced in our FAQ:
    WHM FAQ: How do I use WHM on a PDA?
    It may also help to try a different mobile browser and or check browser configurations on the PDA; some mobile browsers and or browser configurations may make normal access more difficult by restricting features such as JavaScript and or HTML frames.
     
  3. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Okay, I tried that and it allows me to login, but anytime you click a link it logs you out, and you have to login again. I have tested this with four browsers, opera, IE, skyfire and cuweb, all the same.
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    What is the full cPanel version?
    Code:
    # grep '' /usr/local/cpanel/version
    Is HTTP authentication in-use or is cookie-based authentication enabled (via WHM Tweak Settings)?

    Via root SSH access, please provide the output from the following command:
    Code:
    # grep -i "cookieipvalidation\|referrer\|skiphttpauth\|xsrftokens" /var/cpanel/cpanel.config
     
    #4 cPanelDon, Dec 7, 2009
    Last edited: Dec 7, 2009
    oulzac likes this.
  5. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    I am testing on a server running 11.25.0-CURRENT_40255.
    I upgraded to this last night after reading the update log, where it was talking about this version being the most PDA/Smartphone friendly.

    And in Tweak Settings the only option checked is the first one.
    (Validate the IP addresses used in all cookie based logins.)

    And the output of that grep is:
    PHP:
    referrersafety=0
    skiphttpauth
    =0
    I think this might be a WinMo (maybe just 6.5) issue, maybe.
    My old blackberry never had this issue. Although even that didn't load the frames, just the menu frame.
     
  6. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    By the way, thank you for taking the time to respond to this post, I really appreciate it. :D
     
  7. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Thank you for the version and settings information.

    Please toggle the HTTP authentication option so that cookie authentication is used, then re-test; this may only work if the mobile browser configuration allows and saves session cookies.

    You're welcome. :)
     
  8. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    now I am getting some issues with the browsers not wanting to connect to the secure logins (the ssl ports), but that is an issue on the phone. I have not been able to test this yet after turning on the other option. I will need to find out why its not liking the ssl connections first.
     
  9. MikeDVB

    MikeDVB Well-Known Member
    PartnerNOC

    Joined:
    Jun 4, 2008
    Messages:
    212
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Indiana, USA
    If this setting "Validate the IP addresses used in all cookie based logins." does what I think it does it will cause you to drop your log-in every time your IP changes which happens all the time on mobile devices on cellular networks unless you're on a wifi network.

    My suggestion would be to disable that setting and then try again on your WiMo device.
     
Loading...

Share This Page