The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cPanel/whm PHP upgrade broke server, please help!

Discussion in 'General Discussion' started by sagehost, Sep 17, 2009.

  1. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    So last night I logged into WHM and ran the EasyApache upgrade script to upgrade PHP 5.2.6 to PHP 5.2.10, everything seemed to run fine, took just over 30mins. After it said it was finished I rebooted the server and when it came back online PHP didn't work.

    When I try to visit sites that have PHP, say wordpress, the site will not open. In fact Internet Explorer and Firefox both prompts me to save a file instead when I try to visit those sites.

    I've tried re-running EasyApache again but selecting PHP 5.2.6 hoping it would revert the changes, after finished again rebooted but only the same results.

    I then tired to run EasyApache via the SSH command line and once finished rebooted but got again the same results as above.

    Any help in this matter would be GREATLY appreciated.

    Thanks!
     
  2. MattCurry

    MattCurry Well-Known Member

    Joined:
    Aug 18, 2009
    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Tx
    PHP Rebuild

    Hello,

    I am very sorry to see that you are having an issue. I would recommend to go ahead and submit a ticket. There are issues with 5.2.10, we recommend 5.2.9. You can try re-running easyapache with 5.2.9 and see if that resolves the issue. If it doesn't I would go ahead and use the link at the bottom of this post to submit the ticket. Please let me know if you have any other issues.

    Thank you ,
    Matthew Curry
     
Loading...

Share This Page