GodLumeN

Member
Feb 6, 2019
5
0
1
France
cPanel Access Level
Root Administrator
Hello,
I've been notified by cpanel of this error:
[2019-08-07 03:54:36 +0200] E [/usr/local/cpanel/scripts/rpmup] The "/usr/local/cpanel/scripts/rpmup" command (process 28727) reported error number 1 when it ended.

And when I do
/usr/local/cpanel/scripts/rpmu

Code:
--> Finished Dependency Resolution
Error: Package: monodoc-4.6.2-4.el7.x86_64 (@epel)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
info [rpmup] Completed yum execution “--assumeyes --config /etc/yum.conf update --disablerepo=epel”: in 11.780 second(s).
(XID yc8gd5) The system failed to execute yum with the arguments “--assumeyes --config /etc/yum.conf update --disablerepo=epel” because of an error: The “/usr/bin/yum --assumeyes --config /etc/yum.conf update --disablerepo=epel” command (process 25837) reported error number 1 when it ended. : Error: Package: monodoc-4.6.2-4.el7.x86_64 (@epel)
           Requires: mono-core = 4.6.2-4.el7
           Removing: mono-core-4.6.2-4.el7.x86_64 (@epel)
               mono-core = 4.6.2-4.el7
           Updated By: mono-core-6.0.0.319-0.xamarin.1.epel7.x86_64 (mono-centos7-stable)
               mono-core = 6.0.0.319-0.xamarin.1.epel7
           Available: mono-core-3.8.0-1.x86_64 (mono-centos7-stable)
               mono-core = 3.8.0-1
           Available: mono-core-3.10.0-1.x86_64 (mono-centos7-stable)
               mono-core = 3.10.0-1
           Available: mono-core-3.10.0-2.x86_64 (mono-centos7-stable)
               mono-core = 3.10.0-2
           Available: mono-core-3.12.0-0.x86_64 (mono-centos7-stable)
               mono-core = 3.12.0-0
           Available: mono-core-3.12.0-1.x86_64 (mono-centos7-stable)
               mono-core = 3.12.0-1
           Available: mono-core-3.12.0-2.x86_64 (mono-centos7-stable)
               mono-core = 3.12.0-2
           Available: mono-core-3.12.1-0.x86_64 (mono-centos7-stable)
               mono-core = 3.12.1-0
           Available: mono-core-4.0.1-1.x86_64 (mono-centos7-stable)
               mono-core = 4.0.1-1
           Available: mono-core-4.0.1-2.x86_64 (mono-centos7-stable)
               mono-core = 4.0.1-2
           Available: mono-core-4.0.1-3.x86_64 (mono-centos7-stable)
               mono-core = 4.0.1-3
           Available: mono-core-4.0.1-4.x86_64 (mono-centos7-stable)
               mono-core = 4.0.1-4
           Available: mono-core-4.0.1.44-0.xamarin.1.x86_64 (mono-centos7-stable)
               mono-core = 4.0.1.44-0.xamarin.1
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,263
313
Houston
Hello,


While this is an RPM issue being shown when the server is updating it involves a conflict between 3rd party RPMs from 3rd party repositories. I believe the issue is in the naming scheme of the package but I'd suggest checking with a qualified system administrator. If you don't have one you might find one here: System Administration Services