cPanel & WHM update failure in upcp script

Hlone

Registered
Mar 1, 2022
4
1
3
Kinshasa
cPanel Access Level
Root Administrator
Hey
For a while I get a mail saying that cPanel & WHM update failure in upcp script.
In the mail, The cPanel & WHM update process failed for the following reason: Maintenance ended; however, it did not exit cleanly (256). The following events were logged: “scripts/rpmup”. Review the update logs to determine why the update failed.

The problem is that I'm completely lost and I don't know what to do. even reading the log:
Code:
...
...
[2022-03-01 00:06:16 +0100] E [/usr/local/cpanel/scripts/rpmup] The “/usr/local/cpanel/scripts/rpmup” command (process 3665203) reported error number 1 when it ended.
...
[2022-03-01 00:06:28 +0100] Processing: Checking CloudLinux installation
[2022-03-01 00:06:28 +0100] - Processing command `/usr/local/cpanel/bin/cloudlinux_update`
[2022-03-01 00:06:28 +0100] - Finished command `/usr/local/cpanel/bin/cloudlinux_update` in 0.037 seconds
[2022-03-01 00:06:28 +0100] Processing: Updating plugins data cache
[2022-03-01 00:06:28 +0100] - Processing command `/usr/local/cpanel/bin/refresh_plugin_cache`
[2022-03-01 00:06:28 +0100] - Finished command `/usr/local/cpanel/bin/refresh_plugin_cache` in 0.012 seconds
[2022-03-01 00:06:28 +0100] Processing: Ensuring SSL certificate information for CCS is up to date.
[2022-03-01 00:06:28 +0100] - Processing command `/usr/local/cpanel/scripts/ccs-check --run --ssl`
[2022-03-01 00:06:28 +0100] - Finished command `/usr/local/cpanel/scripts/ccs-check --run --ssl` in 0.005 seconds
[2022-03-01 00:06:28 +0100] Processing: Ensure cpanel-plugins yum repo exists
[2022-03-01 00:06:28 +0100] - Finished in 0.516 seconds
[2022-03-01 00:06:28 +0100] Processing: Checking Addon Licenses
[2022-03-01 00:06:28 +0100] - Finished in 0.027 seconds
[2022-03-01 00:06:28 +0100] Processing: Updating Public Suffix List
[2022-03-01 00:06:28 +0100] Processing: Checking End Of Life for current version.
[2022-03-01 00:06:29 +0100] - Finished in 0.049 seconds
[2022-03-01 00:06:29 +0100] Processing:
[2022-03-01 00:06:29 +0100] Maintenance complete.
=> Log closed Tue Mar 1 00:06:29 2022
----------------------------------------------------------------------------------------------------
=> Log opened from cPanel Update (upcp) - Slave (3663278) at Tue Mar 1 00:06:29 2022
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,632
363
cPanel Access Level
Root Administrator
Hey there! This error indicates there is an issue with the RPM update itself, so you'll likely get more details on the error by trying that update outside of the cPanel update. Can you run this command?

Code:
yum update
I would expect that to show an issue and get you pointed in the right direction.
 

Hlone

Registered
Mar 1, 2022
4
1
3
Kinshasa
cPanel Access Level
Root Administrator
Hey there! This error indicates there is an issue with the RPM update itself, so you'll likely get more details on the error by trying that update outside of the cPanel update. Can you run this command?

Code:
yum update
I would expect that to show an issue and get you pointed in the right direction.
By entering this command:
Code:
yum update
I get :
Code:
Last metadata expiration check: 3:40:05 ago on Tue 01 Mar 2022 05:53:07 PM WAT.
Error:
 Problem 1: glibc-devel-2.28-164.el8.i686 has inferior architecture
  - package glibc-static-2.28-164.el8.x86_64 requires glibc-devel = 2.28-164.el8, but none of the providers can be installed
  - cannot install both glibc-devel-2.28-189.el8.x86_64 and glibc-devel-2.28-164.el8.x86_64
  - cannot install the best update candidate for package glibc-devel-2.28-164.el8.x86_64
  - problem with installed package glibc-static-2.28-164.el8.x86_64
 Problem 2: package glibc-static-2.28-164.el8.x86_64 requires glibc-devel = 2.28-164.el8, but none of the providers can be installed
  - package glibc-devel-2.28-164.el8.i686 requires glibc = 2.28-164.el8, but none of the providers can be installed
  - package glibc-devel-2.28-164.el8.x86_64 requires glibc = 2.28-164.el8, but none of the providers can be installed
  - glibc-2.28-164.el8.i686 has inferior architecture
  - cannot install both glibc-2.28-189.el8.x86_64 and glibc-2.28-164.el8.x86_64
  - package libxcrypt-static-4.1.1-6.el8.x86_64 requires glibc-static(x86-64) >= 2.26.9000-46, but none of the providers can be installed
  - cannot install the best update candidate for package glibc-2.28-164.el8.x86_64
  - problem with installed package libxcrypt-static-4.1.1-6.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[CODE]
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,360
1,632
363
cPanel Access Level
Root Administrator
Thanks for that - that's exactly what I was hoping to see.

It seems there are several operating system packages related to Glibc that are causing errors with the update. Specifically, it seems that 32-bit packages are trying to be installed on a 64-bit system.

You'll want to work with your hosting provider to find out why this is happening as Glibc is a core operating system package - if it is improperly handled it could completely break the system, so I'm not able to provide commands or advice here.
 
  • Like
Reactions: Hlone